E - Frogger

Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:从0号点,到1号点,找一条能通过的路,使得这条路中的最大的边,比其它所有可能的路中的边都小。(最小生成树的最大权)
先跑一次最小生成树(kruskal),然后再开一个数组记录从起点到终点这条路中的每一条边权,(这里用dfs查找),最后找出最大的那条边即可。

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <map>
#include <iostream>
#include <vector>
#include <cmath>
#include <cstdlib>
const int MAXM=40005;
const int MAXN=205;
int fa[MAXN];
int tol;
using namespace std;
struct Edge
{
    int u,v;
    double w;
}edge1[MAXM];
struct Edge1
{
    int v;
    double w;
};
vector<Edge1> edge2[MAXN];
struct stone
{
    int x,y;
}point[MAXN];
double edge3[MAXM];
void add(int u,int v,double w)
{
    edge1[tol].u=u;
    edge1[tol].v=v;
    edge1[tol++].w=w;
}
bool cmp(Edge a,Edge b)
{
    return a.w<b.w;
}
int find (int x)
{
    if(fa[x]==-1)
        return x;
    else return fa[x]=find(fa[x]);
}
void kruskal(int n)
{
    for(int i=0;i<MAXN;i++)
    {
        edge2[i].clear();
    }
    memset(fa,-1,sizeof(fa));
    sort(edge1,edge1+tol,cmp);
    int cnt=0;
    double ans=0;
    for(int i=0;i<tol;i++)
    {
        int u=edge1[i].u;
        int v=edge1[i].v;
        double w=edge1[i].w;
        int t1=find(u);
        int t2=find(v);
        if(t1!=t2)
        {
            //这里注意建双向边
            Edge1 tmp;
            tmp.v=v;
            tmp.w=w;
            edge2[u].push_back(tmp);
            tmp.v=u;
            tmp.w=w;
            edge2[v].push_back(tmp);
            //edge2[tol].u=u;
            //edge2[tol].v=v;
            //edge2[tol++].w=w;
//          tol++;
            fa[t1]=t2;
            cnt++;
        }
        if(cnt==n-1)break;
    }
    //printf("%f\n",ans);
    /*if(cnt<n-1)
        return -1;
    else
        return ans;*/
}
int ii=0;
bool dfs(int from,int end,int pre)//用edge3数组记录边
{
    if(from==end)
        return true;
    else
    {
        for(int i=0;i<edge2[from].size();i++)
        {   
            if(edge2[from][i].v!=pre)
            if(dfs(edge2[from][i].v,end,from))
            {
                edge3[ii++]=edge2[from][i].w;
                return true;
            }
        }
    }
    return false;
}
int main (void)
{
    int num;
    int ans=1;
    while(~scanf("%d",&num))
    {
        tol=0;
        if(num==0)
            break;
        for(int i=0;i<num;i++)
        {
            scanf("%d %d",&point[i].x,&point[i].y);
        }
        for(int i=0;i<num;i++)
        {
            for(int j=i+1;j<num;j++)
            {
                double le=sqrt((point[i].x-point[j].x)*
                    (point[i].x-point[j].x)+(point[i].y-point[j].y)*
                    (point[i].y-point[j].y));
                add(i,j,le);
            }
        }
        kruskal(num);
        dfs(0,1,0);
        double maxx=-1;
        for(int i=0;i<ii;i++)
        {
            maxx=max(edge3[i],maxx);
        }
        ii=0;
        printf("Scenario #%d\nFrog Distance = %.3f\n\n",ans++,maxx);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值