还是畅通工程(思想+代码)

58 篇文章 1 订阅
3 篇文章 0 订阅

Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output

对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input

    
    
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output

    
    
3

5

解题思路:

典型的最小生成树的问题,利用krusal算法代码简洁效率高。

但是在构建图的时候尽量不要用邻接矩阵,因为邻接矩阵既浪费空间有耗时间,采用邻接表更好

正解:

#include<cstdio>
#include<algorithm>
typedef struct
{
	int from;
	int to;
	int value;
}Node,*node;
int Find(int *father,int x)
{
	if(x!=father[x])
		father[x]=Find(father,father[x]);
	return father[x];
}
void Union(int *father,int from,int to)
{
	int a=Find(father,from);
	int b=Find(father,to);
	father[a]=b;
}
bool cmp(const Node & a,const Node & b)
{
	return a.value<b.value;//从小到大排序
}
using namespace std;
int main()
{
	int N,i=0;
	while(~scanf("%d",&N),N)
	{
		Node mp[N*N+1];
		int father[N+1];
		for(i=0;i<=N;i++)
			father[i]=i;
        for(i=0;i<N*(N-1)/2 ;i++)
			scanf("%d%d%d",&mp[i].from,&mp[i].to,&mp[i].value);
		sort(mp,mp+N*(N-1)/2,cmp);
		int sum=0;
		for(i=0;i<N*(N-1)/2;i++)
		{
		    if(Find(father,mp[i].from)!=Find(father,mp[i].to))
            {
                Union(father,mp[i].from,mp[i].to);
                sum+=mp[i].value;
            }
			//printf("%d %d %d\n",mp[i].from,mp[i].to,mp[i].value);
		}
		printf("%d\n",sum);
	}
	return 0;
}
开始写时的错误代码:

因为”动态“数组的边界数开的范围不正确

#include<algorithm>//Runtime Error(ACCESS_VIOLATION)
#include<cstdio>
int Find(int * helper,int a)//传递了数组的地址 
{
if(a!=helper[a])
helper[a]=Find(helper,helper[a]);
return helper[a];
}//并查集FIND 
void Union(int * helper,int a,int b)//传递了数组的地址 
{
int x=Find(helper,a);//找a的父节点 
int y=Find(helper,b);//b的父节点 
helper[y]=x;//合并 
}//并查集UNION 
typedef struct M
{
int a;
int b;
int v;
}Node;//存储图的边(u,v)以及对应的值 
bool cmp(const Node & x,const Node & y)
{
return x.v<y.v;
}//sort排序,对值进行降序排序 
using namespace std;
int main(void)
{
int N;
while(scanf("%d",&N)!=EOF&&N)
{
Node vex[N];//存储(u,v)关系(错误) 
int helper[N+1];//新建并查集 
for(int i=0;i<N+1;i++)
helper[i]=i;//并查集初始化 
int T=0;
while(T!=N*(N-1)/2)
scanf("%d%d%d",&vex[T].a,&vex[T].b,&vex[T++].v);
sort(vex,vex+N,cmp);
int sum=0;
for(int i=0;i<N;i++)//K...算法 
{
if(Find(helper,vex[i].a)!=Find(helper,vex[i].b))
{
Union(helper,vex[i].a,vex[i].b);
sum+=vex[i].v;//记录树的总值 

}
printf("%d\n",sum);
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值