还是畅通工程(并查集+贪心)

还是畅通工程(并查集+贪心)

Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。 当N为0时,输入结束,该用例不被处理。

Output
对每个测试用例,在1行里输出最小的公路总长度。

Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output
3
5

[hint]Hint[/hint]
Huge input, scanf is recommended.

本题可以使用prim算法去解决,但是为了加强自己的并查集,所以,本题使用并查集解决。

本题可以通过并查集+贪心解决,先将路径短的排序,再一次解决连成环的问题。
以下代码自己敲写,但是不知是sort超时还是什么特别的原因,杭电OJ无法通过,超时。

#include <cstdio>
#include <cmath>
#include<iostream>
#include<algorithm>
using namespace std;
int f[1005];
struct node
{
	int x, y, z;
}D[1005];
bool cmp(node a, node b) 
{
	return a.z < b.z;
}
int find(int x)
{
	if (f[x] == x)
		return x;
	return(f[x] = find(f[x]));
}
void bing(int x, int y)
{
	int f1 = find(x);
	int f2 = find(y);
	if (f1 != f2)
		f[f2] = f1;
}
int main()
{
	int n;
	while (scanf("%d", &n) != EOF && n != 0)
	{
		for (int i = 1; i <= n; i++)
			f[i] = i;
		int m = n * (n - 1) / 2;
		for (int i = 0; i < m; i++)
			scanf("%d%d%d", &D[i].x, &D[i].y, &D[i].z);
		sort(D, D + m, cmp);
		int cnt = 0;
		for (int i = 0; i < n; i++)
		{
			if (find(D[i].x) != find(D[i].y))
			{
				bing(D[i].x, D[i].y);
				cnt = cnt + D[i].z;
			}
		}
		printf("%d\n", cnt);
	}
	return 0;
}

于是,在借鉴他人写法后,改进自己的sort,完美通过。

借鉴比较来自:https://blog.csdn.net/TY_GYY/article/details/88374643

#include <cstdio>
#include <cmath>
#include<iostream>
#include<algorithm>
using namespace std;
int f[1005];
int cnt;
struct P {
	int x, y, z;
	bool operator<(const P& a)const {
		return z < a.z;
	}
}D[5005];
int find(int x)
{
	if (f[x] == x)
		return x;
	return(f[x] = find(f[x]));
}
void bing(int x, int y,int z)
{
	int f1 = find(x);
	int f2 = find(y);
	if (f1 != f2)
		f[f2] = f1, cnt += D[z].z;
}
int main()
{
	int n;
	while (scanf("%d", &n) != EOF && n != 0)
	{
		for (int i = 1; i <= n; i++)
			f[i] = i;
		int m = n * (n - 1) / 2;
		cnt = 0;
		for (int i = 0; i < m; i++)
			scanf("%d%d%d", &D[i].x, &D[i].y, &D[i].z);
		sort(D, D + m);
		for (int i = 0; i < m; i++)
			bing(D[i].x, D[i].y,i);
		printf("%d\n", cnt);
	}
	return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值