Secret Poems HihoCoder - 1632(一道模拟题)

Problem Description

The Yongzheng Emperor ( 13 13 13 December 1678 – 8 1678 – 8 16788 October 1735 1735 1735), was the fifth emperor of the Qing dynasty of China. He was a very hard-working ruler. He cracked down on corruption and his reign was known for being despotic, efficient, and vigorous.

Yongzheng couldn’t tolerate people saying bad words about Qing or him. So he started a movement called “words prison”. “Words prison” means literary inquisition. In the famous Zhuang Tinglong Case, more than 70 70 70 people were executed in three years because of the publication of an unauthorized history of the Ming dynasty.

In short, people under Yongzheng’s reign should be very careful if they wanted to write something. So some poets wrote poems in a very odd way that only people in their friends circle could read. This kind of poems were called secret poems.

A secret poem is a N×N matrix of characters which looks like random and meaning nothing. But if you read the characters in a certain order, you will understand it. The order is shown in figure 1 below:
在这里插入图片描述
      figure 1                           figure2
      
Following the order indicated by arrows, you can get “THISISAVERYGOODPOEMITHINK”, and that can mean something.

But after some time, poets found out that some Yongzheng’s secret agent called “Mr. blood dripping” could read this kind of poems too. That was dangerous. So they introduced a new order of writing poems as shown in figure2. And they wanted to convert the old poems written in old order as figure1 into the ones in new order. Please help them.

Input

There are no more than 10 10 10 test cases.

For each test case:

The first line is an integer N ( 1 &lt; = N &lt; = 100 ) N( 1 &lt;= N &lt;= 100) N(1<=N<=100), indicating that a poem is a N × N N×N N×N matrix which consist of capital letters.

Then N N N lines follow, each line is an N N N letters string. These N N N lines represent a poem in old order.

Output

For each test case, convert the poem in old order into a poem in new order.

Sample Input

5
THSAD 
IIVOP 
SEOOH 
RGETI 
YMINK
2
AB
CD
4
ABCD
EFGH
IJKL
MNOP

Sample Output

THISI
POEMS
DNKIA
OIHTV
OGYRE

AB
DC

ABEI
KHLF
NPOC
MJGD

题目大意:
给出一个 n ∗ n n*n nn 的字符数组按照图一方式形成一个字符串,然后按照图二的方式把一个新的二维数组进行输出;
思路:进行搜索模拟,参照网上的代码;

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int n,s;
char s1[101][101],s3[101][101];
char s2[101101];
int dfs(int x,int y,int s){
    s2[s]=s1[x][y];
    if(x==n-1&&y==n-1)
        return 0;
    if((y==0&&x%2!=0&&(n%2==0&&x<n-1||n%2!=0))||(y==n-1&&n%2==0&&x%2!=0&&x<n-1||y==n-1&&n%2!=0&&x%2==0))
	dfs(x+1,y,s+1);      
	 /*1、在第一列,行的下标为偶数时;(1)n为偶数,并且不在最后一行时;
                                   (2)n为奇数时;
    2、在最后一列时:(1)n为偶数,行的下标不为偶数,且不在最后一行时;
                     (2)n为奇数,行的下标为偶数时;
    以上情况都是(x,y)=>(x+1,y);
  */
    else if((x==0&&y%2==0&&(n%2!=0&&y<n-1||n%2==0))||x==n-1&&(n%2==0&&y%2==0&&y<n-1||n%2!=0&&y%2!=0))
	dfs(x,y+1,s+1);
	/*  1、在第一行,列数为偶数时:(1)n为偶数;
                               (2)n为奇数,且不为最后一列时;
    2、在最后一行时:(1)n为偶数,列的下标为偶数,且不为最后一列时;
                     (2)n为奇数,列的下标为奇数时;
    以上情况都是(x,y)=>(x,y+1);
*/
    else if((x+y)%2==0)//行和列的下标之和为偶数时:(x,y)=>(x-1,y+1);
        dfs(x-1,y+1,s+1);
    else if((x+y)%2!=0)//行和列的下标之和为奇数时:(x,y)=>(x+1,y-1);
        dfs(x+1,y-1,s+1);
}
int prt(int x,int y,int s){
    s3[x][y]=s2[s];
    if(s==n*n-1)return 0;
    if(s3[x][y+1]=='1'&&(x-1<0||s3[x-1][y]!='1'))
        prt(x,y+1,s+1);
    else if(s3[x+1][y]=='1')
        prt(x+1,y,s+1);
    else if(s3[x][y-1]=='1')
        prt(x,y-1,s+1);
    else if(s3[x-1][y]=='1')
        prt(x-1,y,s+1);
}
int main(){
    int i,j;
    while(~scanf("%d",&n)){
        for(i=0; i<n; i++)
            scanf("%s",s1[i]);
        dfs(0,0,0);
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                s3[i][j]='1';
        prt(0,0,0);
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                printf(j==n-1?"%c\n":"%c",s3[i][j]);
    }
    return 0;
}

时间是检验真理的唯一标准

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值