Secret Poems HihoCoder - 1632(模拟)

Secret Poems HihoCoder - 1632

The Yongzheng Emperor (13 December 1678 – 8 October 1735), was the fifth emperor of the Qing dynasty of China. He was a very hard-working ruler. He cracked down on corruption and his reign was known for being despotic, efficient, and vigorous.

Yongzheng couldn’t tolerate people saying bad words about Qing or him. So he started a movement called “words prison”. “Words prison” means literary inquisition. In the famous Zhuang Tinglong Case, more than 70 people were executed in three years because of the publication of an unauthorized history of the Ming dynasty.

In short, people under Yongzheng’s reign should be very careful if they wanted to write something. So some poets wrote poems in a very odd way that only people in their friends circle could read. This kind of poems were called secret poems.

A secret poem is a N×N matrix of characters which looks like random and meaning nothing. But if you read the characters in a certain order, you will understand it. The order is shown in figure 1 below:

[f.png]

            figure 1                                                           figure 2

Following the order indicated by arrows, you can get “THISISAVERYGOODPOEMITHINK”, and that can mean something.

But after some time, poets found out that some Yongzheng’s secret agent called “Mr. blood dripping” could read this kind of poems too. That was dangerous. So they introduced a new order of writing poems as shown in figure 2. And they wanted to convert the old poems written in old order as figure1 into the ones in new order. Please help them.

Input

There are no more than 10 test cases.

For each test case:

The first line is an integer N( 1 <= N <= 100), indicating that a poem is a N×N matrix which consist of capital letters.

Then N lines follow, each line is an N letters string. These N lines represent a poem in old order.

Output

For each test case, convert the poem in old order into a poem in new order.

Sample Input

5
THSAD 
IIVOP 
SEOOH 
RGETI 
YMINK
2
AB
CD
4
ABCD
EFGH
IJKL
MNOP

Sample Output

THISI
POEMS
DNKIA
OIHTV
OGYRE
AB
DC
ABEI
KHLF
NPOC
MJGD
题意:

将题目给的第一种形式的矩阵转变成第二种输出

分析:

费劲的模拟

code:

#include <bits/stdc++.h>
using namespace std;
int n;
char G[110][110];
char ans[110][110];
char ans2[110][110];
int main(){
    while(~scanf("%d",&n)){
        for(int i = 0; i < n; i++){
            scanf("%s",G[i]);
        }
        int x = 0,y = 0;
        int row = 0,col = 0;
        int flag = 0;
        int flag2 = 0;
        while(1){
            ans[row][col] = G[x][y];
            if((x == 0 || y == 0 || x == n-1 || y == n-1) && flag2 == 0){
                if(x == n-1 && y == n-1) break;
                if(x == 0 && y == 0){
                    y++;
                    flag = 1;
                    flag2 = 1;
                }
                else if(x == 0 || y == n-1){
                    if(x == 0 && y == n-1) x++;
                    else if(x == 0) y++;
                    else if(y == n-1) x++;
                    flag = 1;
                    flag2 = 1;
                }
                else if(x == n-1 || y == 0){
                    if(x == n-1) y++;
                    else if(y == 0) x++;
                    flag = 2;
                    flag2 = 1;
                }
            }
            else{
                flag2 = 0;
                if(flag == 1){
                    x++;
                    y--;
                }
                else if(flag == 2){
                    x--;
                    y++;
                }
            }
            col++;
            if(col == n){
                col = 0;
                row++;
            }
            if(row == n) break;
        }
        row = 0;
        col = 0;
        flag = 0;
        memset(ans2,'#',sizeof(ans2));
        for(int i = 0; i < n; i++){
            for(int j = 0; j < n; j++){
                ans2[row][col] = ans[i][j];
                if(flag == 0){
                    col++;
                    if(col == n-1 || ans2[row][col+1] != '#') flag = 1;
                }
                else if(flag == 1){
                    row++;
                    if(row == n-1 || ans2[row+1][col] != '#') flag = 2;
                }
                else if(flag == 2){
                    col--;
                    if(col == 0 || ans2[row][col-1] != '#') flag = 3;
                }
                else if(flag == 3){
                    row--;
                    if(ans2[row-1][col] != '#') flag = 0;
                }
            }
        }
        for(int i = 0; i < n; i++){
            for(int j = 0; j < n; j++){
                putchar(ans2[i][j]);
            }
            putchar('\n');
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值