POJ 3641 Pseudoprime numbers

Pseudoprime numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8846 Accepted: 3723

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

Source


题意and 题解:若a^p%p=a,而且a不是素数,则输出yes,所以如果a是素数或者a不是素数但是却不满足那个式子就输出no.由于此题数很大,所以要用到快速幂的方法。

<span style="font-family:SimSun;font-size:18px;">#include<cstdio>
__int64 fun(__int64 a,__int64 p)
{
	__int64 c=p,ans=1,base=a;
	while(p)
	{
		if(p&1)
		{
			ans=(ans*base)%c;  //同余定理,否则可能会因数值太大而越界 
		}
		base=(base*base)%c;
		p=p/2;
	}
	return ans;
}
__int64 gcd(__int64 a)
{
	if(a%2==0)
		return 0;
	for(__int64 i=3;i*i<a;i+=2)
	{
		if(a%i==0)
			return 0;
	}
	return 1;
}
int main()
{
	__int64 p,a;
	while(~scanf("%I64d%I64d",&p,&a)&&!(a==0&&p==0))
	{
		if(gcd(p))   //若a是素数 
		{
			printf("no\n");
			continue;
		}
		else if(a==fun(a,p))
		{
			printf("yes\n");
			continue;
		}
		else
			printf("no\n");
	}
	return 0;
}</span><span style="font-size:14px;font-family: 'Times New Roman', Times, serif;">
</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值