POJ 1363 Rails

Rails
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 31530 Accepted: 12267

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

Source

Central Europe 1997


题解:输入N,为车厢1~N,再输入N个数表示需要排成的车厢序列(车厢序列可输入多组,以0为结束标志),若经过如图中转站1~N个车厢能排成那个序列就输出Yes,否则输出No.


<span style="font-family:SimSun;font-size:18px;">#include<stdio.h>
#include<stack>
using namespace std;
int main()
{
	int n,a;
	while(scanf("%d",&n),n)
	{
	<span style="white-space:pre">	</span>while(1)
		{
		<span style="white-space:pre">	</span>int flag=0;
			int t=1;
			stack<int>st;
                        st.push(t);   //车厢 1先进栈 
			for(int i=1;i<=n;i++)
			{
				scanf("%d",&a); // a为需要排成的队列,一个一个的输入 
				if(a==0)
				
				{
					flag=1;
					break;
				}
				if(st.empty())  //如果栈为空则继续压栈 
				{
					t++;
					st.push(t);
				}
				int top=st.top();
				while(top!=a)
                <span style="white-space:pre">		</span>{
                   <span style="white-space:pre">		</span> <span style="white-space:pre">	</span>if(t==n)   //即 t为最后一节车厢 
                       <span style="white-space:pre">			</span>break;
                    <span style="white-space:pre">			</span>t++;
                    <span style="white-space:pre">			</span>st.push(t);
                    <span style="white-space:pre">			</span>top=st.top();
                <span style="white-space:pre">		</span>}
                <span style="white-space:pre">		</span>if(top==a)
                	<span style="white-space:pre">		</span>st.pop();
			<span style="white-space:pre">	</span>}
			<span style="white-space:pre">	</span>if(flag)
                <span style="white-space:pre">			</span>break;
            <span style="white-space:pre">			</span>if(st.empty())
                <span style="white-space:pre">			</span>printf("Yes\n");
            <span style="white-space:pre">			</span>else
                <span style="white-space:pre">			</span>printf("No\n");
		<span style="white-space:pre">	</span>}
		<span style="white-space:pre">	</span>printf("\n");
	}
	return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值