poj3159 Candies(查分约束最短路)

Candies
Time Limit: 1500MS Memory Limit: 131072K
Total Submissions: 34043 Accepted: 9570

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow Mlines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

Source

POJ Monthly--2006.12.31, Sempr


思路:强烈推荐此博客, 看完之后就懂了。(Dijikstra和spfa)


#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int INF=0x3f3f3f3f;
int head[30010], n, m, cnt, dis[30010], inq[30010], visCount[30010], vis[30010], path[30010];

struct node{
    int u, w;
    bool operator < (const node& tmp) const{
        return w>tmp.w;
    }
};
struct side{
    int v, w, next;
}edg[150010];

void init(){
    memset(head, -1, sizeof(head));
}

void addEdg(int u, int v, int w){
    edg[cnt].v=v;
    edg[cnt].w=w;
    edg[cnt].next=head[u];
    head[u]=cnt++;
}
//其中一种方法注释掉了,根据自己喜好二者任选其一。
void Dijkstra(int s){
    priority_queue<node> q;
    for(int i=1; i<=n; i++)
        dis[i]=i==s? 0:INF;
    q.push((node){s, dis[s]});
    while(!q.empty())
    {
        node it=q.top();
        q.pop();
        if(vis[it.u])
            continue;
        vis[it.u]=1;
        for(int i=head[it.u]; i!=-1; i=edg[i].next)
        {
            int v=edg[i].v, w=edg[i].w;
            if(dis[v]>dis[it.u]+w)
            {
                dis[v]=dis[it.u]+w;
                path[it.u]=v;
                q.push((node){v, dis[v]});
            }
        }

    }
}

/*bool spfa(int s){
   priority_queue<node> q;
    for(int i=1; i<=n; i++)
    {
        dis[i]= i==s? 0:INF;
        inq[i]= (i==s);
        visCount[i]=0;
    }
    q.push((node){s, dis[s]});
    while(!q.empty()){
        node it=q.top();
        q.pop();
        if(++visCount[it.u] > n)
            return true;
        inq[it.u]=0;
        for(int e=head[it.u]; e!=-1; e=edg[e].next)
        {
            int v=edg[e].v, w=edg[e].w;
            if(dis[v]>dis[it.u]+w)
            {
                dis[v]=dis[it.u]+w;
                if(!inq[v])
                {
                    inq[v]=1;
                    q.push((node){v, dis[v]});
                }
            }
        }
    }
}*/

int main(){
    init();
    scanf("%d%d", &n, &m);
    for(int i=1; i<=m; i++)
    {
        int u, v, w;
        scanf("%d%d%d", &u, &v, &w);
        addEdg(u, v, w);
    }
    Dijkstra(1);
    //spfa(1);
    printf("%d\n", dis[n]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值