HDU 6024(dp)

47 篇文章 0 订阅

Building Shops

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1767    Accepted Submission(s): 633


Problem Description
HDU’s  n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these  n classrooms.

The total cost consists of two parts. Building a candy shop at classroom  i would have some cost  ci. For every classroom  P without any candy shop, then the distance between  P and the rightmost classroom with a candy shop on  P's left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
 

Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer  n(1n3000), denoting the number of the classrooms.
In the following  n lines, each line contains two integers  xi,ci(109xi,ci109), denoting the coordinate of the  i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
 

Output
For each test case, print a single line containing an integer, denoting the minimal cost.
 

Sample Input
 
 
3 1 2 2 3 3 4 4 1 7 3 1 5 10 6 1
 

Sample Output
 
 
5 11
 

Source
 

Recommend
jiangzijing2015

思路:dp,自己贪心做的,错了。借这道题再复习一下贪心和dp区别。  
不同点: 
贪心算法: 
1.贪心算法中,作出的每步贪心决策都无法改变,因为贪心策略是由上一步的最优解推导下一步的最优解,而上一部之前的最优解则不作保留。 
2.由(1)中的介绍,可以知道贪心法正确的条件是:每一步的最优解一定包含上一步的最优解。 

动态规划算法: 
1.全局最优解中一定包含某个局部最优解,但不一定包含前一个局部最优解,因此需要记录之前的所有最优解 
2.动态规划的关键是状态转移方程,即如何由以求出的局部最优解来推导全局最优解 
3.边界条件:即最简单的,可以直接得出的局部最优解

#include<cstdio>
#include<cstring>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const ll INF=0x3f3f3f3f3f3f3f3f;
const int maxn=3e3+10;
int n;
struct node{
	ll x, c;
}pos[maxn];

bool cmp(node a, node b){
	return a.x<b.x;
}

ll dp[maxn][2];//表示第i间屋子建candy 和 不建candy 的最优解

int main()
{
	while(~scanf("%d", &n)){
		for(int i=1; i<=n; i++)
			scanf("%lld%lld", &pos[i].x, &pos[i].c);
		sort(pos+1, pos+1+n, cmp);
		dp[1][1]=pos[1].c;
		for(int i=1; i<=n; i++) dp[i][0]=INF;
		for(int i=2; i<=n; i++)
		{
			dp[i][1]=min(dp[i-1][0], dp[i-1][1]) + pos[i].c;
			ll sum=0;
			for(int j=i-1; j>=1; j--)
			{
				sum+=(i-j) * (pos[j+1].x-pos[j].x);
				dp[i][0]=min(dp[i][0], dp[j][1]+sum);
			}
		}
		printf("%lld\n", min(dp[n][0], dp[n][1]));
	}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值