【2018 ICPC北京网赛】 A Saving Tang Monk II(BFS)

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng’en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace, and he wanted to reach Tang Monk and rescue him.

The palace can be described as a matrix of characters. Different characters stand for different rooms as below:

‘S’ : The original position of Sun Wukong

‘T’ : The location of Tang Monk

‘.’ : An empty room

‘#’ : A deadly gas room.

‘B’ : A room with unlimited number of oxygen bottles. Every time Sun Wukong entered a ‘B’ room from other rooms, he would get an oxygen bottle. But staying there would not get Sun Wukong more oxygen bottles. Sun Wukong could carry at most 5 oxygen bottles at the same time.

‘P’ : A room with unlimited number of speed-up pills. Every time Sun Wukong entered a ‘P’ room from other rooms, he would get a speed-up pill. But staying there would not get Sun Wukong more speed-up pills. Sun Wukong could bring unlimited number of speed-up pills with him.

Sun Wukong could move in the palace. For each move, Sun Wukong might go to the adjacent rooms in 4 directions(north, west,south and east). But Sun Wukong couldn’t get into a ‘#’ room(deadly gas room) without an oxygen bottle. Entering a ‘#’ room each time would cost Sun Wukong one oxygen bottle.

Each move took Sun Wukong one minute. But if Sun Wukong ate a speed-up pill, he could make next move without spending any time. In other words, each speed-up pill could save Sun Wukong one minute. And if Sun Wukong went into a ‘#’ room, he had to stay there for one extra minute to recover his health.

Since Sun Wukong was an impatient monkey, he wanted to save Tang Monk as soon as possible. Please figure out the minimum time Sun Wukong needed to reach Tang Monk.
输入

There are no more than 25 test cases.

For each case, the first line includes two integers N and M(0 < N,M ≤ 100), meaning that the palace is a N × M matrix.

Then the N×M matrix follows.

The input ends with N = 0 and M = 0.
输出

For each test case, print the minimum time (in minute) Sun Wukong needed to save Tang Monk. If it’s impossible for Sun Wukong to complete the mission, print -1
样例输入

2 2
S#
#T
2 5
SB###
##P#T
4 7
SP.....
P#.....
......#
B...##T
0 0

样例输出

-1
8
11

直接BFS就好了,按照规则模拟即可,手残了,忘了把起点压进去,WA了5发。。 v i s [ i ] [ j ] [ k ] vis[i][j][k] vis[i][j][k]标记当前位置的氧气量即可。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll maxn = 202;
char maze[maxn][maxn];
struct node{
    ll x,y,oxy;
    ll step;
};
bool operator<(node a,node b){
    return a.step>b.step;
}
ll n,m;
bool check(ll x,ll y){
    return x>=1&&x<=n&&y>=1&&y<=m;
}
ll dir[4][2]={{-1,0},{0,-1},{0,1},{1,0}};
bool vis[202][202][100];
ll bfs(ll sx,ll sy){
    priority_queue<node> que;
    memset(vis,0,sizeof(vis));
    node st;
    st.x=sx;
    st.y=sy;
    st.step=0;
    st.oxy=0;
    vis[sx][sy][0]=1;
    que.push(st);
    ll ans=-1;
    while(!que.empty()){
        node rt=que.top();
        que.pop();
        if(maze[rt.x][rt.y]=='T'){
            ans=rt.step;
            break;
        }
        for(ll i=0;i<4;i++){
            ll dx=rt.x+dir[i][0];
            ll dy=rt.y+dir[i][1];
            st.x=dx;
            st.y=dy;
            if(!check(st.x,st.y)||vis[st.x][st.y][rt.oxy]) continue;
            vis[st.x][st.y][rt.oxy]=1;
            if(maze[st.x][st.y]=='#'){
                if(rt.oxy>0){
                    st.oxy=rt.oxy-1;
                    st.step=rt.step+2;
                    que.push(st);
                }
            }
            else if(maze[st.x][st.y]=='.'||maze[st.x][st.y]=='T'||maze[st.x][st.y]=='S'){
                st.oxy=rt.oxy;
                st.step=rt.step+1;
                que.push(st);
            }
            else if(maze[st.x][st.y]=='P'){
                st.step=rt.step;
                st.oxy=rt.oxy;
                que.push(st);
            }
            else if(maze[st.x][st.y]=='B'){
                for(ll i=1;i<=5;i++){
                    if(rt.oxy+i<=5){
                        st.oxy=rt.oxy+i;
                        st.step=rt.step+2*i-1;
                        que.push(st);
                    }
                }
            }
        }
    }
    return ans;
}
int main(){
    while(cin>>n>>m&&(m+n)){
        for(ll i=1;i<=n;i++){
            for(ll j=1;j<=m;j++) cin>>maze[i][j];
        }
        ll sx,sy;
        for(ll i=1;i<=n;i++){
            for(ll j=1;j<=m;j++){
                if(maze[i][j]=='S'){
                    sx=i;
                    sy=j;
                    cout<<bfs(sx,sy)<<endl;
                    break;
                }
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值