1904 奶牛慢跑
题目
奶牛们又出去锻炼蹄子去了!
有 NN 头奶牛在无限长的单行道上慢跑,且跑步方向为坐标值增大的方向。
每头奶牛在跑道上开始奔跑的位置互不相同,一些奶牛的奔跑速度可能相同,也可能不同。
由于跑道是单行道,十分狭窄,奶牛们无法相互超越。
当一头速度很快的牛追上另一头牛时,她必须减速至与另一头牛速度相同以免发生碰撞,并成为同一跑步小组的一员。此时,两头牛可以视为在同一点上。
最终,再也没有奶牛会撞到(追上)其他奶牛了。
约翰想知道在这种情况下,会剩下多少个跑步小组。
输入格式
第一行包含整数 NN.
接下来 NN 行,每行包含一头奶牛的初始位置和跑步速度。
所有奶牛的初始位置各不相同,且是按照递增顺序给出的。
输出格式
输出一个整数,表示最终剩下的小组数量。
数据范围
1≤N≤1051≤N≤105,
初始位置范围 [0,109][0,109],
跑步速度范围 [1,109][1,109]
输入样例:
5
0 1
1 2
2 3
3 2
6 1
输出样例:
2
解释与代码
思路:用结构体来存位置和速度,先排序,从远往近遍历,后面的<=前面的最小的时ans自增
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <iostream>
#include <sstream>
#include <set>
#include <map>
#include <queue>
#include <bitset>
#include <vector>
#include <limits.h>
#include <assert.h>
#include <functional>
#include <numeric>
#include <ctime>
//#include <ext/pb_ds/assoc_container.hpp>
//#include <ext/pb_ds/tree_policy.hpp>
#define pb push_back
#define ppb pop_back
#define lbnd lower_bound
#define ubnd upper_bound
#define endl '\n'
#define mll map<ll,ll>
#define msl map<string,ll>
#define mls map<ll, string>
#define rep(i,a,b) for(ll i=a;i<b;i++)
#define repr(i,a,b) for(ll i=b-1;i>=a;i--)
#define trav(a, x) for(auto& a : x)
#define pll pair<ll,ll>
#define vl vector<ll>
#define vll vector<pair<ll, ll>>
#define vs vector<string>
#define all(a) (a).begin(),(a).end()
#define F first
#define S second
#define sz(x) (ll)x.size()
#define hell 1000000007
#define DEBUG cerr<<"/n>>>I'm Here<<</n"<<endl;
#define display(x) trav(a,x) cout<<a<<" ";cout<<endl;
#define what_is(x) cerr << #x << " is " << x << endl;
#define ini(a) memset(a,0,sizeof(a))
#define ini2(a,b) memset(a,b,sizeof(a))
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define sc ll T;cin>>T;for(ll Q=1;Q<=T;Q++)
#define lowbit(x) x&(-x)
#define pr printf
#define ordered_set tree<ll, null_type,less<ll>, rb_tree_tag,tree_order_statistics_node_update>
#define FAST ios_base::sync_with_stdio(false);cin.tie(0);cout.tie(0);
#define DBG(x) \
(void)(cout << "L" << __LINE__ \
<< ": " << #x << " = " << (x) << '\n')
#define TIE \
cin.tie(0);cout.tie(0);\
ios::sync_with_stdio(false);
//#define long long int
//using namespace __gnu_pbds;
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 0x3f3f3f3f;
const int maxn = 1e5+10;
const ll N = 1000000007;
const ull N2 = 1000000007;
int ans = 1;
struct cow {
int l, v;
} c[maxn];
bool cmp(cow a, cow b) {
return a.l > b.l;
}
void solve() {
int n;
cin>>n;
for (int i=0; i<n; i++) {
cin>>c[i].l>>c[i].v;
}
sort(c, c+n, cmp);
int lastv = c[0].v;
for (int i=1; i<n; i++) {
if (c[i].v <= lastv) {
ans++;
lastv = c[i].v;
}
}
cout<<ans<<endl;
}
int main()
{
// TIE;
// #ifndef ONLINE_JUDGE
// freopen ("input.txt","r",stdin);
// #else
// #endif
solve();
// sc{solve();}
// sc{cout<<"Case "<<Q<<":"<<endl;solve();}
}