1082 Read Number in Chinese (25分) 解析


Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output Fu first if it is negative. For example, -123456789 is read as Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu. Note: zero (ling) must be handled correctly according to the Chinese tradition. For example, 100800 is yi Shi Wan ling ba Bai.
Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.
Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.
Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai

解决方法

分析:字符串数组

题目大意

按照汉语的读法读数字。

解决思路

按照四位一个分隔,先读出四位,然后再读权重。
每四位的读法规则如下:
♦负号需要读出,输出的是Fu,不是fu
♦数字末尾的连续的0,不读
♦每四位之间的多个0只读一个0

代码

#include<iostream>
#include<string>
using namespace std;
int main()
{
	string s;
	cin >> s;
	string num[10] = { "ling","yi","er","san","si","wu","liu","qi","ba","jiu" };
	string weight[6] = { "","Shi","Bai","Qian","Wan","Yi" };
	int left = 0, right = s.length() - 1, len = s.length();
	if (s[0] == '-') 
	{
		cout << "Fu";
		left++;
	}
	while (left + 4 <= right) right -= 4;
	while (left < len)
	{
		bool flag = false;
		while (left <= right)
		{
			if (left > 0 && s[left] == '0') flag = true;
			else
			{
				if (flag == true)
				{
					cout << " ling";
					flag = false;
				}
				if (left > 0) cout << " ";
				cout << num[s[left] - '0'];
				if (left != right) cout << " " << weight[right - left];
			}
			left++;
		}
		if (right != len - 1) cout << " " << weight[(len-1-right) / 4 + 3];
		right += 4;
	}
	return 0;
}

后记

这个解法参考了晴神的思路,不是百分之百的原创。。。明天再来解一次

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值