[C/C++] 1012 The Best Rank (25 分)

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

思路:
定义一个二维数组用来存储排名:
第一维是学号,第二维是四个科目
默认数组元素为0,代表没有数据存入,便于查找指定学号(若有效,则非零)
进行4次排序,每次分别在二维数组存储对应科目的排名(纵向)
然后对于指定的id,找出排名最靠前的,并输出当前值和对应的科目(横向)

注意:
①数组过大(106),应定义在main函数的外面
②对于这个代码,Rank首字母大写,否则[Error] reference to 'rank' is ambiguous:就是自己定义的rank变量名称与库函数中的函数名rank有重名现象,我们通常做法是将定义的变量的首字母大写,一般就不会与库函数中的重名了

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

struct info{
	int id;
	int grade[4];
	int rank[4];
}stu[2010];

int now;//当前比较
bool cmp(info a, info b){
	return a.grade[now] > b.grade[now]; 
}

int Rank[1000000][4] = {0};
int main()
{
	int n, m;
	scanf("%d%d",&n,&m);
	for( int i=0; i<n; i++){
		scanf("%d %d %d %d",&stu[i].id,&stu[i].grade[1],&stu[i].grade[2],&stu[i].grade[3]);
		stu[i].grade[0] = stu[i].grade[1] + stu[i].grade[2] + stu[i].grade[3];
	}
	
	for( now=0; now<4; now++){
		sort(stu, stu+n, cmp);
		Rank[stu[0].id][now] = 1;
		for(int i=1;i<n;i++){
			if(stu[i].grade[now] == stu[i-1].grade[now]) Rank[stu[i].id][now] = Rank[stu[i-1].id][now];
			else Rank[stu[i].id][now] = i+1;
		}
	}
	
	char sub[4] = {'A','C','M','E'};
	int search;
	for( int i=0; i<m; i++){
		scanf("%d",&search);
		if(Rank[search][0] == 0) printf("N/A\n");
		else{
			int flag = 0;
			for( int j=1;j<4;j++){
				if(Rank[search][j]<Rank[search][flag]){
					flag = j;
				}
			}
			printf("%d %c\n",Rank[search][flag],sub[flag]);
		}
	} 
	return 0;
}

另:柳婼没有使用二维数组,方法可以参考

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值