1012 The Best Rank (25分)——C语言实现

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题目大意:

给定若干学生信息,C语言最高分为第一名,数学最高分为第二名,英语最高分为第三名,平均分最高分为第四名。若等级相同,则按照A > C > M > E的顺序输出;若所搜索学生id不在所给信息中,输出N/A。

思路:

(哈哈,为了简洁用了sort函数,如果想要纯粹的C语言,可以自己写个排序函数,取代sort函数)使用rank[]存储四科排名;score[4]存储四科成绩:score[0]为平均成绩、score[1]为C语言成绩、score[2]为数学成绩、score[3]为英语成绩;best为最高排名。

代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{
	int id, best;
	int rank[4], score[4]; //rank存储四科排名
}Student[2010];
int flag, a[1000000];
bool cmp(node x, node y){
	return x.score[flag] > y.score[flag];
}
int main(){
	int n, m, i, id;
	scanf("%d %d", &n, &m);
	for(i = 0; i < n; i++){
		scanf("%d %d %d %d", &Student[i].id, &Student[i].score[1], &Student[i].score[2], &Student[i].score[3]);
		Student[i].score[0] = (Student[i].score[1]+Student[i].score[2]+Student[i].score[3])/3 + 0.5;
	}
	for(flag = 0; flag <= 3; flag++){//对每科成绩排序
		sort(Student, Student+n, cmp);
		Student[0].rank[flag] = 1;
		for(i = 1; i < n; i++){
			Student[i].rank[flag] = i+1;
			if(Student[i].score[flag] == Student[i-1].score[flag]){
				Student[i].rank[flag] = Student[i-1].rank[flag];
			}
		}
	}
	for(i = 0; i < n; i++){//寻找每个同学的最高排名在rank中的下标
		a[Student[i].id] = i+1;
		Student[i].best = 0;
		int minn = Student[i].rank[0];
		for(int j = 1; j <=3; j++){
			if(Student[i].rank[j] < minn){
				minn = Student[i].rank[j];
				Student[i].best = j;
			}
		}
	}
	char c[5] = {'A', 'C', 'M', 'E'};
	for(i = 0; i < m; i++){
		scanf("%d", &id);
		if(a[id]){
			int best = Student[a[id]-1].best;
			printf("%d %c\n", Student[a[id]-1].rank[best], c[best]);
		}
		else{
			printf("N/A\n");
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值