Vue2.0 之 自带浏览器里无法打开(兼容处理) - 解决方案

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/dx18520548758/article/details/80265470

Vue 之 android内嵌H5页面不显示出现这个问题,原因有很多

首先,别急,请看下面的推荐方案:

1、找个android真机测试下(机型版本为4.4以上),真机联调测试(如果不知道怎么联调,那么请看这里:Android真机 - 联调chrome调试)


2、如果报 报错 vuex requires a Promise polyfill in this browser.那么,就是兼容性不够好,请看下面的解决方案:

首先,使用 node 安装 *babel-polyfill 命令*

npm install --save-dev -polyfill
  • 1


解决方案如下:

方案1:在 webpack.config.js 文件中,entry 入口处修改,加入即可

"babel-polyfill":"babel-polyfill",//用来解决的兼容性
  • 1

例如:

entry: {
    "babel-polyfill":"babel-polyfill",//用来解决的兼容性
    app: path.resolve(__dirname, config.entry.module + "/app.js"),
    vendor: config.entry.vendor
},
  • 1
  • 2
  • 3
  • 4
  • 5


方案2:不修改webpack的情况下,在你的主入口文件头部加入,例如:app.js中加入即可

import 'babel-polyfill'
  • 1

例如:

import 'babel-polyfill'

import Vue from 'vue';
Vue.config.debug = true;
  • 1
  • 2
  • 3
  • 4



方案3:也就是使用cdn的资源,以js的文件加入到html页面:例如:

<script src="https://cdn.bootcss.com/babel-polyfill/6.23.0/polyfill.min.js"></script>


1.首先确定手机安卓系统4.0以上。

2.在页面引入https://cdn.bootcss.com/babel-polyfill/6.23.0/polyfill.min.js 在页面处理兼容问题。

3.单页面或者web-view 尽量不要用es6进行代码开发,用了也没事找个网址进行es6转es5(https://babeljs.io/repl/)。

本次遇到的问题是老板的华为手机自带浏览器不兼容vue2.0。

没有更多推荐了,返回首页