nyoj 148 fibonacci数列(二) 【矩阵快速幂】

fibonacci数列(二)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875
来源
POJ
上传者
hzyqazasdf

思路:

      要注意每一个数在矩阵中代表的什么含义,然后再做,否则很容易出错!

     第一个矩阵中第一个数代表f(2),依次类推,就能得到所有的f的值了!

代码:

#include <stdio.h>
#include <string.h>
int n;
struct Maxtri
{
	int r,c;
	int a[5][5];
};
Maxtri ori,res;
void init()
{
	memset(res.a,0,sizeof(res.a));
	for(int i=1;i<=2;i++)
		res.a[i][i]=1;
	ori.a[1][1]=1;ori.a[1][2]=1;
	ori.a[2][1]=1;ori.a[2][2]=0;
}
Maxtri maxtri(Maxtri x,Maxtri y)
{
	Maxtri z;
	memset(z.a,0,sizeof(z.a));
	for(int i=1;i<=2;i++)
	{
		for(int k=1;k<=2;k++)
		{
			if(x.a[i][k]==0)	continue;
			for(int j=1;j<=2;j++)
			{
				z.a[i][j]=(z.a[i][j]+(x.a[i][k]*y.a[k][j])%10000)%10000;
			}
		}
	}
	return z;
}
void maxtri_mod()
{
	while(n)
	{
		if(n%2!=0)
			res=maxtri(res,ori);
		ori=maxtri(ori,ori);
		n/=2;
	}
}
int main()
{
	while(scanf("%d",&n)&&(n!=-1))
	{
		if(n==0)
		{
			printf("0\n");
			continue;
		}
		init();
		n=n-1;
		maxtri_mod();
		printf("%d\n",res.a[1][1]);
	}
	return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值