NYOJ 148 fibonacci数列(二)

19 篇文章 0 订阅

fibonacci数列(二)

时间限制: 1000 ms | 内存限制: 65535 KB
难度: 3
描述

In the Fibonacci integer sequence, F0 = 0, F1 = 1, andFn =Fn − 1 +Fn − 2 forn ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

 

输入
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
输出
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
样例输入
0
9
1000000000
-1
样例输出
0
34
6875
 
矩阵快速幂...好高级生气
 如:求A^156,而156(10)=10011100(2) 

也就有A^156=>(A^4)*(A^8)*(A^16)*(A^128) 考虑到因子间的联系,我们从二进制10011100中的最右端开始计算到最左端。细节就说到这,下面给核心代码:

 

 
while(N)
 {
                if(N&1)
                       res=res*A;
                N>>=1;
                A=A*A;
 }

 

 

 
贴个本题的最优:
 
#include <stdio.h>
int f(int x,int y,int a,int b)
{
    return a*x+b*y;
}
int main()
{
    int n,i,j,k;
    while(scanf("%d",&n)&&~n)
    { 
        int t[2][2];
        int a[2][2]=
        {
            1,0,
            1,0
        };
        int b[2][2]=
        {
            1,1,
            1,0
        };
       
        while(n)
        {
            if(n&1)
            {
                t[0][0]=f(a[0][0],a[0][1],b[0][0],b[1][0])%10000;
                t[0][1]=f(a[0][0],a[0][1],b[0][1],b[1][1])%10000;
                t[1][0]=f(a[1][0],a[1][1],b[0][0],b[1][0])%10000;
                t[1][1]=(a[1][0],a[1][1],b[0][1],b[1][1])%10000;
                a[0][0]=t[0][0];
                a[0][1]=t[0][1];
                a[1][0]=t[1][0];
                a[1][1]=t[1][1];
            }
            t[0][0]=f(b[0][0],b[0][1],b[0][0],b[1][0])%10000;
            t[0][1]=f(b[0][0],b[0][1],b[0][1],b[1][1])%10000;
            t[1][0]=f(b[1][0],b[1][1],b[0][0],b[1][0])%10000;
            t[1][1]=f(b[1][0],b[1][1],b[0][1],b[1][1])%10000;
            b[0][0]=t[0][0];
            b[0][1]=t[0][1];
            b[1][0]=t[1][0];
            b[1][1]=t[1][1];
            n=n>>1;
        }
        printf("%d\n",a[0][1]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值