hdoj 1432 Lining Up

Lining Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1261    Accepted Submission(s): 362


Problem Description
``How am I ever going to solve this problem?" said the pilot. 


Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 

Your program has to be efficient! 
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer on a line by itself indicating the number of points, followed by N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. No pair will occur twice in one test case. 

 

Output
For each test case, the output consists of one integer representing the largest number of points that all lie on one line, one line per case.
 

Sample Input
  
  
5 1 1 2 2 3 3 9 10 10 11
 

Sample Output
  
  
3
 

Source
 

Recommend
lcy
 

Statistic |  Submit |  Discuss |  Note

代码:
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
	int x,y;
}a[705];
int f(node a,node b,node c)
{
	if((a.x-c.x)*(b.y-c.y)==(b.x-c.x)*(a.y-c.y))
		return 1;
	else return 0;
}
int max(int a,int b)
{
	if(a>b)
		return a;
	return b;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a[i].x,&a[i].y);
		}
		int ans=0;
		for(int i=0;i<n;i++)
		{
			for(int j=i+1;j<n;j++)
			{
				int cou=0;
				for(int k=j+1;k<n;k++)
				{
					if(f(a[i],a[j],a[k]))
					{
						cou++;
					}
				}
				ans=max(ans,cou);//挑选和i,j在同一条直线上的点的个数 
			}//如果和i,j点在同一条直线上,那么满足det(x1)*det(y2)==det(x2)*det(y1) 
		}
		printf("%d\n",ans+2);//最少两个点在一个直线上 
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值