[POJ 3061]Subsequence

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

简述题意,找出数列中连续的一段数字串,他们的和≥s,求这个数字串的最小长度。如果没有这种数字串则输出0。

题解:
听说有奇技淫巧,但是我还是老老实实写了个二分答案。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
#include<cmath>
#include<algorithm>
#define ll long long
#define LiangJiaJun main
#define eps 1e-9
#define INF 1999122700
using namespace std;
int T;
int n,s,a[100004];
bool check(int x){
     int vec=0;
     for(int i=1;i<=x;i++)vec+=a[i];
     if(vec>=s)return 1;
     for(int i=2;i<=n-x+1;i++){
         vec-=a[i-1];vec+=a[i+x-1];
         if(vec>=s)return 1;
     }
     return 0;
}
int w33ha(){
    scanf("%d%d",&n,&s);
    for(int i=1;i<=n;i++)scanf("%d",&a[i]);
    int ans=INF,l=1,r=n;
    while(l<=r){
        int mid=(l+r)>>1;
        if(check(mid)){
            r=mid-1;ans=mid;
        }
        else l=mid+1;
    }
    if(ans==INF)puts("0");
    else printf("%d\n",ans);
    return 0;
}
int LiangJiaJun(){
    scanf("%d",&T);
    while(T--)w33ha();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值