[HDU2846]Repository

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)

Problem Description

When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.

Input

There is only one case. First there is an integer P(1<=P<=10000) P ( 1 <= P <= 10000 ) representing the number of the merchanidse names in the repository. The next P lines each contain a string (it’s length isn’t beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) Q ( 1 <= Q <= 100000 ) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.

Output

For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.

Sample Input

20
ad
ae
af
ag
ah
ai
aj
ak
al
ads
add
ade
adf
adg
adh
adi
adj
adk
adl
aes
5
b
a
d
ad
s

Sample Output

0
20
11
11
2

题意
给你一个由P个字符串组成的字典,长度不超过20。接下来有Q组询问,每组询问一个字符串,问这个字符串是字典中多少个字符串的子串。

题解
对于每个插入的字符串,我们将其所有后缀插入trie树,然后在trie树的每个节点都记录该节点属于多少个字符串。用相同编号来统一同一个字符串的不同后缀。

#include<bits/stdc++.h>
#define LiangJiaJun main
using namespace std;
int ch[500004][26];
int cnt[500004],last[500004],sz;
int p,q;
int insert(char *s,int be,int ed,int value){
    int u=0,to;
    for(int i=be;i<=ed;i++){
        to=s[i]-'a';
        if(!ch[u][to]){
            ch[u][to]=sz++;
        }
        u=ch[u][to];
        if(last[u]!=value){
            last[u]=value;
            ++cnt[u];
        }
    }
    return 0;
}
int find(char *s,int be,int ed){
    int u=0,to;
    for(int i=be;i<=ed;i++){
        to=s[i]-'a';
        if(!ch[u][to])return 0;
        u=ch[u][to];
    }
    return cnt[u];
}
char s[24];
int w33ha(){
    sz=1;
    scanf("%d",&p);
    for(int i=1;i<=p;i++){
        scanf("%s",s+1);
        int l=strlen(s+1);
        for(int j=1;j<=l;j++)insert(s,j,l,i);
    }
    scanf("%d",&q);
    while(q--){
        scanf("%s",s+1);
        int l=strlen(s+1);
        printf("%d\n",find(s,1,l));
    }
    return 0;
}
int LiangJiaJun(){
    w33ha();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值