Time Limit: 10 Sec
Memory Limit: 162 MB
Description
N个矩形,排成一排. 现在希望用尽量少的矩形海报Cover住它们.
Input
第一行给出数字N,代表有N个矩形.N在[1,250000] 下面N行,每行给出矩形的长与宽.其值在[1,1000000000]
Output
最少数量的海报数.
Sample Input
5
1 2
1 3
2 2
2 5
1 4
Sample Output
4
题解:单调栈裸题,维护一个单调递减栈,然后对于每个新入栈的元素,所有栈内和他同一高度的元素对答案的贡献-1
#include<bits/stdc++.h>
#define LiangJiaJun main
using namespace std;
int n,st[250004],t;
int w33ha(){
t=0;
int ans=n;
for(int i=1;i<=n;i++){
int x,y;scanf("%d%d",&x,&y);
while(t>0&&st[t]>=y){
ans-=(st[t]==y);
t--;
}
st[++t]=y;
}
printf("%d\n",ans);
return 0;
}
int LiangJiaJun(){
while(scanf("%d",&n)!=EOF)w33ha();
return 0;
}