poj3069 Saruman's Army

Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3556 Accepted: 1812

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positionsx1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source



这道题主要是考察区间覆盖问题,贪心。

说有一些点,这里需要标记一些点,使每个点周围R的区域内一定有被标记的点。

不妨从最开始的点开始考虑问题,最开始的点周围R区域内一定有一个被标记的点,显然他本身被标记并不是一个最佳方案。所以就要考虑在R范围内,离这个点最远的点为标记点,标记点右侧在R之外但是离标记点最近的点是下一次考虑的起始点。

这样想清楚之后,就不难写出算法。

#include <iostream>
#include <algorithm>

using namespace std;


int d[1005];
int N,R;



int main()
{
    while(cin >> R >> N && R!=-1&&N!=-1)
    {
        for (int i = 1;i <= N;i++)
            cin >> d[i];

        sort(d+1,d+N+1);//这里注意一定要排序

        int ans = 1;//初始一定存在一个标记点

        int flag;
        int start = 1;//每一轮开始的起始位置

        for (int i = 1;i <= N;i++)
        {
            if (d[i] <= d[start] + R)
                flag = i;
            else if (d[i] > d[start] + R)
            {
                //上一个flag点是标记点
                for (int j = flag + 1;j <= N;j++)
                {
                    if (d[flag] + R < d[j])
                    {
                        i = j - 1;
                        start = j;
                        ans++;
                        break;
                    }
                }
            }

        }
        cout << ans << endl;

    }





}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值