主席树模板题

主席树模板题

Keen On Everything But Triangle

题目描述

N sticks are arranged in a row, and their lengths are a1,a2,…,aN.
There are Q querys. For i-th of them, you can only use sticks between li-th to ri-th. Please output the maximum circumference of all the triangles that you can make with these sticks, or print −1 denoting no triangles you can make.

输入

There are multiple test cases.
Each case starts with a line containing two positive integers N,Q(N,Q≤105).
The second line contains N integers, the i-th integer ai(1≤ai≤109) of them showing the length of the i-th stick.
Then follow Q lines. i-th of them contains two integers li,ri(1≤li≤ri≤N), meaning that you can only use sticks between li-th to ri-th.
It is guaranteed that the sum of Ns and the sum of Qs in all test cases are both no larger than 4×105.

输出

For each test case, output Q lines, each containing an integer denoting the maximum circumference.

样例输入

复制样例数据

5 3
2 5 6 5 2
1 3
2 4
2 5

样例输出
13
16
16

ps:邝斌的模板,查询区间第k大的值。


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
#include <iostream>

#include <algorithm>

#include <cstdio>



using namespace std;



typedef long long ll;

const int maxn = 1e5+10;



const int M=maxn*20;

ll n,q,m,tot;

ll a[maxn], t[maxn];

ll T[maxn], lson[M], rson[M], c[M];

void Init_hash()

{

    for(ll i=1;i<=n;i++)

          t[i] = a[i];

    sort(t+1,t+1+n);

    m=unique(t+1,t+1+n)-t-1;

}



ll build(ll l,ll r)

{

    ll root=tot++;

    c[root]=0;

    if(l!=r)

    {

        ll mid=(l+r)>>1;

        lson[root]=build(l,mid);

        rson[root]=build(mid+1,r);

    }

    return root;

}



ll Hash(ll x)

{

    return lower_bound(t+1,t+1+m,x)-t;

}



ll update(ll root,ll pos,ll val)

{

    ll newroot=tot++,tmp=newroot;

    c[newroot]=c[root]+val;

    ll l=1,r=m;

    while(l<r)

    {

        ll mid=(l+r)>>1;

        if(pos<=mid)

        {

            lson[newroot]=tot++;

            rson[newroot]=rson[root];

            newroot=lson[newroot];

            root=lson[root];

            r=mid;

        }

        else

        {

            rson[newroot]=tot++;

            lson[newroot]=lson[root];

            newroot=rson[newroot];

            root=rson[root];

            l=mid+1;

        }

        c[newroot]=c[root]+val;

        }

        return tmp;

}



ll query(ll left_root,ll right_root,ll k)

{

    ll l = 1, r = m;

    while( l < r)

    {

        ll mid = (l+r)>>1;

        if(c[lson[left_root]]-c[lson[right_root]] >= k )

        {

            r = mid;

            left_root = lson[left_root];

            right_root = lson[right_root];

        }

        else

        {

            l = mid + 1;

            k -= c[lson[left_root]] - c[lson[right_root]];

            left_root = rson[left_root];

            right_root = rson[right_root];

        }

    }

    return l;

}

int main()

{

    while(scanf("%lld%lld",&n,&q)==2){

        tot=0;//一直没写这个,段错误。

        for(ll i=1;i<=n;i++){

            scanf("%lld",&a[i]);

        }

        Init_hash();

        T[n+1]=build(1,m);

        for(ll i=n;i;i--){

            ll pos=Hash(a[i]);

            T[i]=update(T[i+1],pos,1);



        }

        ll l,r;

        while(q--){

            scanf("%lld%lld",&l,&r);

            if(r-l<2) {

                printf("-1\n");

                continue;

            }

            ll ans=0;

            bool flag=false;

            ll x=query(T[l],T[r+1],r-l+1);

            ll y=query(T[l],T[r+1],r-l);

            ll cnt=0;

            for(ll i=r-l-1;i>=1;i--){

                cnt++;

                if(cnt>50) break;

                int z=query(T[l],T[r+1],i);

                if(t[z]+t[y]>t[x]) {

                    ans=t[x]+t[y]+t[z];

                    flag=true;

                    break;

                }

                x=y;

                y=z;

            }

            if(flag) {

                printf("%lld\n",ans);

            }

            else printf("-1\n");

        }

    }

    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值