HDU 6601 [2019 Multi-University Training Contest 2]

Keen On Everything But Triangle

Problem Description

N sticks are arranged in a row, and their lengths are a1,a2,…,aN.

There are Q querys. For i-th of them, you can only use sticks between li-th to ri-th. Please output the maximum circumference of all the triangles that you can make with these sticks, or print −1 denoting no triangles you can make.

Input

There are multiple test cases.

Each case starts with a line containing two positive integers N,Q(N,Q≤105).

The second line contains N integers, the i-th integer ai(1≤ai≤109) of them showing the length of the i-th stick.

Then follow Q lines. i-th of them contains two integers li,ri(1≤li≤ri≤N), meaning that you can only use sticks between li-th to ri-th.

It is guaranteed that the sum of Ns and the sum of Qs in all test cases are both no larger than 4×105.

Output

For each test case, output Q lines, each containing an integer denoting the maximum circumference.

Sample Input

5 3
2 5 6 5 2
1 3
2 4
2 5

Sample Output

13
16
16

思路

题目意思是说,给出n个数,让你从所给的区间中找出能构成三角形的三个数的周长最大值。找区间内的最大的三个数,不能凑成三角形就往下推一个位,因为斐波那契数列是最极限不能构成三角形的数据,第49个斐波那契数已经超出题目给的109范围。所以最多跑49次一定可以得到结果。区间第k大问题,没学过主席树,套了一个区间第k小的模板,反向求最大。最后因为输出那里不是long long类型WA了好久……

代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

const int MAXN = 100010;
const int M = MAXN * 30;
int n,q,m,tot;
int a[MAXN], t[MAXN];
int T[MAXN], lson[M], rson[M], c[M];
void Init_hash() {
	for(int i = 1; i <= n; i++)
		t[i] = a[i];
	sort(t+1,t+1+n);
	m = unique(t+1,t+1+n)-t-1;
}
int build(int l,int r) {
	int root = tot++;
	c[root] = 0;
	if(l != r) {
		int mid = (l+r)>>1;
		lson[root] = build(l,mid);
		rson[root] = build(mid+1,r);
	}
	return root;
}
int hashh(int x) {
	return lower_bound(t+1,t+1+m,x) - t;
}
int update(int root,int pos,int val) {
	int newroot = tot++, tmp = newroot;
	c[newroot] = c[root] + val;
	int l = 1, r = m;
	while(l < r) {
		int mid = (l+r)>>1;
		if(pos <= mid) {
			lson[newroot] = tot++;
			rson[newroot] = rson[root];
			newroot = lson[newroot];
			root = lson[root];
			r = mid;
		} else {
			rson[newroot] = tot++;
			lson[newroot] = lson[root];
			newroot = rson[newroot];
			root = rson[root];
			l = mid+1;
		}
		c[newroot] = c[root] + val;
	}
	return tmp;
}
int query(int left_root,int right_root,int k) {
	int l = 1, r = m;
	while( l < r) {
		int mid = (l+r)>>1;
		if(c[lson[left_root]]-c[lson[right_root]] >= k ) {
			r = mid;
			left_root = lson[left_root];
			right_root = lson[right_root];
		} else {
			l = mid + 1;
			k -= c[lson[left_root]] - c[lson[right_root]];
			left_root = rson[left_root];
			right_root = rson[right_root];
		}
	}
	return l;
}
int main() {
	while(scanf("%d%d",&n,&q) != EOF) {
		tot = 0;
		for(int i = 1; i <= n; i++)
			scanf("%d",&a[i]);
		Init_hash();
		T[n+1] = build(1,m);
		for(int i = n; i ; i--) {
			int pos = hashh(a[i]);
			T[i] = update(T[i+1],pos,1);
		}
		while(q--) {
			int l,r;
			bool flag = false;
			scanf("%d%d",&l,&r);
			for(int i=0; i<=r-l-2; i++) {
				if(t[query(T[l], T[r + 1], r-l+1-i)] < t[query(T[l], T[r + 1], r-l-i)] + t[query(T[l], T[r + 1], r-l-1-i)]) {
					cout << 1ll * t[query(T[l], T[r + 1], r-l+1-i)] + 1ll * t[query(T[l], T[r + 1], r-l-i)] + 1ll * t[query(T[l], T[r + 1], r-l-1-i)] << endl;;
					flag = true;
					break;
				}
			}
			if(!flag) {
				puts("-1");
			}
		}
	}
	return 0;
}

题目来源

HDU 6601 Keen On Everything But Triangle

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
GeoPandas是一个开源的Python库,旨在简化地理空间数据的处理和分析。它结合了Pandas和Shapely的能力,为Python用户提供了一个强大而灵活的工具来处理地理空间数据。以下是关于GeoPandas的详细介绍: 一、GeoPandas的基本概念 1. 定义 GeoPandas是建立在Pandas和Shapely之上的一个Python库,用于处理和分析地理空间数据。 它扩展了Pandas的DataFrame和Series数据结构,允许在其中存储和操作地理空间几何图形。 2. 核心数据结构 GeoDataFrame:GeoPandas的核心数据结构,是Pandas DataFrame的扩展。它包含一个或多个列,其中至少一列是几何列(geometry column),用于存储地理空间几何图形(如点、线、多边形等)。 GeoSeries:GeoPandas中的另一个重要数据结构,类似于Pandas的Series,但用于存储几何图形序列。 二、GeoPandas的功能特性 1. 读取和写入多种地理空间数据格式 GeoPandas支持读取和写入多种常见的地理空间数据格式,包括Shapefile、GeoJSON、PostGIS、KML等。这使得用户可以轻松地从各种数据源中加载地理空间数据,并将处理后的数据保存为所需的格式。 2. 地理空间几何图形的创建、编辑和分析 GeoPandas允许用户创建、编辑和分析地理空间几何图形,包括点、线、多边形等。它提供了丰富的空间操作函数,如缓冲区分析、交集、并集、差集等,使得用户可以方便地进行地理空间数据分析。 3. 数据可视化 GeoPandas内置了数据可视化功能,可以绘制地理空间数据的地图。用户可以使用matplotlib等库来进一步定制地图的样式和布局。 4. 空间连接和空间索引 GeoPandas支持空间连接操作,可以将两个GeoDataFrame按照空间关系(如相交、包含等)进行连接。此外,它还支持空间索引,可以提高地理空间数据查询的效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值