Pie

Pie

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 80   Accepted Submission(s) : 28
Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 

Input
One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2
 

Sample Output
 
 
25.1327 3.1416 50.2655


值得研究!

这道题目就是很典型的变形二分,首先要想出一个表达式来计算

然后二分解方程,直到找到那个符合的数字


#include <stdio.h>
#include <math.h>
#define N 10000
#define PI acos(-1.0)
//n表示共有多少蛋糕
//f表示吃蛋糕的总人数
int n, f;
int ri[N + 5];
double v[N + 5];
//参数是体积,判断该体积下,可以分到蛋糕的人数是否大于等于指定人数
int isSuitable(double vol)
{
    int num, i;
    num = 0;
    for (i = 1; i <= n; i++)
    {
        num += (int)(v[i] / vol);
    }
    if (num < f)
        return 0;
    else
        return 1;
}
void main()
{
    
    int zu;
    double min, max, mid, sum, res;
    sum = 0;
    scanf("%d", &zu);
    for (int j = 1; j <= zu; j++)
    {
        //input  输入
        scanf("%d %d", &n, &f);
        for (int i = 1; i <= n; i++)
        {
            scanf("%d", &ri[i]);
            v[i] = ri[i] * ri[i];
            sum += v[i];
        }
        //把自己也加上
        f += 1;
        min = 0;
        max = sum / f;
        //首先要判断最大值,如果最大值都满足条件,那么就答案就是这个最大值
        if (isSuitable(max))
            res = max;
        else
        {
            //找方程的解
            while (max - min > 1e-6)
            {
                mid = (max + min) / 2;
                if (isSuitable(mid))
                    min = mid;
                else
                    max = mid;
            }
        }
        
        printf("%.4f\n", min * PI);
    }
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值