1017. Queueing at Bank (25)

原题地址:http://www.patest.cn/contests/pat-a-practise/1017

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

解题思路:简单模拟题,将用户按照到达时间顺序排列,依次寻找符合要求的窗口(空闲的窗口或者最早结束服务的窗口)对用户进行服务,记录服务用户的数量和用户的等待时间。

代码如下:

#include <stdio.h>
#include <algorithm>
#include <cstring>
#include <queue>
#define MAXN 10002
#define MAXW 102
typedef struct custom{
  char aTime[10];
  int arTime;
  int sTime;
}cust;
typedef struct windows{
  int finish_Time;
}win;

cust c[MAXN];
win w[MAXW];
int N, K;


int parseTime(char* s){
  return ((s[0]-'0')*10+(s[1]-'8'))*60*60 + ((s[3]-'0')*10 + (s[4]-'0'))*60 + (s[6]-'0')*10 + (s[7]-'0');  
}

int cmp(const void* _a, const void* _b){
  cust a = *(cust*)_a;
  cust b = *(cust*)_b;
  return strcmp(a.aTime,b.aTime);  
}

int main(){
  double wait = 0.0;
  int count = 0;
//freopen("1017.txt","r",stdin);
  scanf("%d%d",&N,&K);
  for(int i = 0; i < N; i++){
    scanf("%s%d",&(c[i].aTime),&(c[i].sTime));
    if(c[i].sTime > 90) c[i].sTime = 90;
    c[i].arTime = parseTime(c[i].aTime);
  }
  qsort(c,N,sizeof(c[0]),cmp);
  for(int i = 0; i < K; i++)
    w[i].finish_Time = 0;

  for(int j = 0; j < N; j ++){
//============ min needs to be big enough =========================================
    int min = 86405;
    int id = -1;
    for(int i = 0; i < K; i++){
      if(c[j].arTime >= w[i].finish_Time && c[j].arTime < 32401){
        w[i].finish_Time = c[j].arTime + c[j].sTime*60;
        count++;
        id = -1;
        break;
      }
      if(min > w[i].finish_Time){
        min = w[i].finish_Time;
        id = i;
      }
    }
    if(id >= 0 && c[j].arTime < 32401){
      w[id].finish_Time, c[j].arTime);
        wait += (w[id].finish_Time - c[j].arTime);
        w[id].finish_Time += c[j].sTime*60;
        count++;
    }
  }
    if(count == 0){
        printf("0.0");
        return 0;   
    }
    printf("%.1f",(wait/60)/count);  
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值