1017 Queueing at Bank (25)(25 分)

uppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:

8.2


题目大意是,银行中有k个窗口,n个客户,银行每天8:00-17:00办理业务。给出客户的到达时间和办理时间,按照到达时间依次办理业务,求所有客户的平均等待时间。需要注意的是,17:00之后到达的客户不处理,不计入平均时间;每个客户办理 时间不超过一小时,超出按一小时处理。

解题思路:每次都找出当前结束时间最早的窗口,如果下一客户的到达时间比最早结束时间早,那么客户需要等待,等待时间为办理结束时间 - 客户到达时间。如果客户到达时,已有空闲窗口,那么需要维护窗口的结束时间。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>

using namespace std;
struct node
{
    int arrive;
    int time;
}a[10005];
bool cmp(node a , node b)
{
    return a.arrive < b.arrive;
}

int main()
{
    int n,k;
    cin>>n>>k;
    int cnt = 0;
    int window[k];
    double ans = 0.0;
    fill(window,window+k,8*3600);  //初始化窗口时间
    for(int i = 0; i < n; ++i)
    {
        int H,M,S,time;
        scanf("%d:%d:%d %d",&H,&M,&S,&time);
        int come = H*3600 + M*60 + S;
        if(come > 17*3600) //忽略1700之后的客户
            continue;
        time = time > 60 ? 60:time;
        a[cnt].arrive = come;
        a[cnt++].time = time * 60;
    }
    sort(a,a+cnt,cmp);
    for(int i = 0; i < cnt; i++)
    {
        int fast = window[0];
        int temp = 0;
        for(int j = 1; j < k; j++)
        {
            if(fast > window[j])
            {
                fast = window[j];
                temp = j;
            }
        }
        if(a[i].arrive > fast)
        {
            window[temp] = a[i].arrive + a[i].time;
        }
        else
        {
            ans = ans + window[temp] - a[i].arrive;
            window[temp] += a[i].time;
        }
    }
    if(cnt == 0)
        cout<<"0.0"<<endl;
    else
        printf("%.1f",ans/60.0/cnt);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值