杭电1800-Flying to the Mars

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8319    Accepted Submission(s): 2692


Problem Description

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.
 

Input
Input file contains multiple test cases.
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
  
  
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
  
  
1 2
题意:就要求一群士兵怎样用最少的魔法扫把飞去火星,而且能力高只能带能力低的而且只能带一个
题目第一行给出n(士兵的数量)
下面n行给出士兵的能力,问你需要最少需要多少扫把
AC代码:
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
const int MAX=3001;
int s[MAX];
int t[MAX][MAX];
int k[MAX];
using namespace std;
bool cmp(int x,int y)
{
    return x>y;
}
int main()
{
    int n,i,j,a,b,p;
    while(cin>>n)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d",&s[i]);
        }
        sort(s,s+n,cmp);
        t[0][0]=s[0];
        a=1;
        b=1;
        for(i=1;i<n;i++)
        {
            p=0;
            if(s[i]<t[0][b-1])
            {
                t[0][b]=s[i];
                b+=1;
            }
            else
            {
                for(j=1;j<a;j++)
                {
                    if(s[i]<t[j][k[j]-1])
                    {
                        t[j][k[j]]=s[i];
                        k[j]+=1;
                        p=1;
                        break;
                    }
                }
                if(p!=1)
                {
                    k[a]=0;
                    t[a][k[a]]=s[i];
                    k[a]+=1;
                    a+=1;
                }
            }
        }
        cout<<a<<endl;
    }
    return 0;
}
//此题和我写1257是同样题型,方法是一模一样,这里没写解释,所以不懂的可以看看我写的1257的解题报告

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Flying Saucer是一个Java库,可以将HTML文档转换为PDF格式。它是基于开源的HTML和CSS渲染引擎——WebKit的一个分支。 要使用Flying Saucer将HTML转换为PDF,您可以按照以下步骤进行操作: 1. 首先,将Flying Saucer添加到您的Java项目中。您可以通过Maven或手动下载JAR文件来完成。Flying Saucer的最新版本可以在其官方网站上找到。 2. 创建一个Java类,并导入所需的Flying Saucer类。 3. 在代码中,使用Flying Saucer提供的API加载和渲染HTML文档。您可以使用`ITextRenderer`类来执行此操作。 4. 设置输出路径和文件名,然后使用`ITextRenderer`类将渲染的内容保存为PDF文件。 下面是一个简单的示例代码,演示了如何使用Flying Saucer将HTML转换为PDF: ```java import org.xhtmlrenderer.pdf.ITextRenderer; public class HtmlToPdfConverter { public static void main(String[] args) { String inputHtmlPath = "path/to/input.html"; String outputPdfPath = "path/to/output.pdf"; try { // Create an instance of ITextRenderer ITextRenderer renderer = new ITextRenderer(); // Set the input HTML document renderer.setDocument(new File(inputHtmlPath)); // Render the HTML document to PDF renderer.layout(); // Save the rendered PDF to the output path OutputStream outputStream = new FileOutputStream(outputPdfPath); renderer.createPDF(outputStream); outputStream.close(); System.out.println("PDF conversion completed successfully."); } catch (Exception e) { e.printStackTrace(); } } } ``` 您需要将`inputHtmlPath`替换为实际的HTML文件路径,并将`outputPdfPath`替换为要保存的PDF文件路径。 请注意,Flying Saucer对CSS的支持相对较好,但不是完全完善的。因此,在将HTML转换为PDF之前,最好确保您的HTML文档与Flying Saucer兼容,并且在渲染过程中没有任何问题。 希望这能帮助到您!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值