HDOJ--1800Flying to the Mars!!贪心

传送门

In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the broomstick needed .
For example : 
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed. 
 

Input
Input file contains multiple test cases. 
In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 

Output
For each case, output the minimum number of broomsticks on a single line.
 

Sample Input
  
  
4 10 20 30 04 5 2 3 4 3 4
 

Sample Output
  
  
1 2

题目大意:每个士兵可以教一个低水平的士兵,每个士兵可以有一个老师也可以有一个学生也可以都没有,老师可以带着学生在一个broomsticks上,例如:6->4->3->2;现在问如何使broomsticks的数目达到最少!!!!


思路:贪心,每个老师可以带一个学生,我最开始的思路是从高往低处找,每一个最高的人可以带着等级低的人,例如:有level 1 3 3 4 5 6,
6带着5,5带4,4带3,3带1,再加上一个3,总共需要两个broomsticks!
转换思路:每一个soldier都必须在一个broomsticks上,那么最多水平相同的soldier的数目就是broomsticks的数目!!因为一个broomsticks上不可能同时有两个相同level!!!

代码:


#include<stdio.h>
#include<algorithm>

using namespace std;

#define maxnumber 3005
int soldierlevel[maxnumber];

int main()
{
	int i,t,N;
	int s;
	while(scanf("%d",&N)!=EOF)
	{
		for(i=0;i<N;i++)
		{
			scanf("%d",&soldierlevel[i]);
		}
		sort(soldierlevel,soldierlevel+N);//排序,让相同的士兵排在相邻位置 
		s=1;    //士兵为0,broomsticks为1 
		t=1;
		for(i=1;i<N;i++)
		{
			if(soldierlevel[i]==soldierlevel[i-1])//如果level相同,增加一个broomsticks 
			{
				t++;
				if(t>s)
					s=t;
				continue;
			}
			t=1;                //不相同,则重新计数! 
		}
		printf("%d\n",s);
	}
}



  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值