POJ3067 Japan

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19777 Accepted: 5355

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output:
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source

Southeastern Europe 2006

题意:就是说西海岸有n个城市,东海岸就m个城市,将这些点用线连起来,看有多少个交点,不可能三条线交于一点。。。
分析:首先用手画了一下,就是用题目给的数据画的,首先将1和4连起来,然后发现,只要左边大于一的点连到右边小于4的点都会产生一个交点,而右边的点全部连起来不就是3么,不就是逆序数么,然后就发现了左边按从小到大排序,左边相等时,右边从小到大,求右边的逆序数就是答案了。。。。。。这题一提交,RE!!!!!!,看了好久,离散化下还是RE。。。。最后看了一个多小时。。。。点数组太小了。。。。应该是MAX*MAX

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=1010;
int c[MAX];
struct Node
{
    int a,b;
}p[MAX*MAX];
int lowbit(int x)
{
    return x&(-x);
}
void add(int x,int val)
{
    while(x<MAX)
    {
        c[x]+=val;
        x+=lowbit(x);
    }
}
__int64 sum(int x)
{
    __int64 ans=0;
    while(x>0)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}
bool cmp1(Node x,Node y)
{
    if(x.a==y.a)
        return x.b<y.b;
    return x.a<y.a;
}
int main()
{
    int n,m,i,k,flag=1,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        for(i=1;i<=k;i++)
        {
            scanf("%d%d",&p[i].a,&p[i].b);
        }
        sort(p+1,p+k+1,cmp1);
        __int64 ans=0;
        memset(c,0,sizeof(c));
        for(i=1;i<=k;i++)
        {
            add(p[i].b,1);
            ans+=i-sum(p[i].b);
        }
        printf("Test case %d: %I64d\n",flag++,ans);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值