HDU2457 DNA repair

DNA repair

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1244    Accepted Submission(s): 674



Problem Description
Biologists finally invent techniques of repairing DNA that contains segments causing kinds of inherited diseases. For the sake of simplicity, a DNA is represented as a string containing characters 'A', 'G' , 'C' and 'T'. The repairing techniques are simply to change some characters to eliminate all segments causing diseases. For example, we can repair a DNA "AAGCAG" to "AGGCAC" to eliminate the initial causing disease segments "AAG", "AGC" and "CAG" by changing two characters. Note that the repaired DNA can still contain only characters 'A', 'G', 'C' and 'T'.

You are to help the biologists to repair a DNA by changing least number of characters.
 

Input
The input consists of multiple test cases. Each test case starts with a line containing one integers N (1 ≤ N ≤ 50), which is the number of DNA segments causing inherited diseases.
The following N lines gives N non-empty strings of length not greater than 20 containing only characters in "AGCT", which are the DNA segments causing inherited disease.
The last line of the test case is a non-empty string of length not greater than 1000 containing only characters in "AGCT", which is the DNA to be repaired.

The last test case is followed by a line containing one zeros.
 

Output
For each test case, print a line containing the test case number( beginning with 1) followed by the
number of characters which need to be changed. If it's impossible to repair the given DNA, print -1.
 

Sample Input
  
  
2 AAA AAG AAAG 2 A TG TGAATG 4 A G C T AGT 0
 

Sample Output
  
  
Case 1: 1 Case 2: 4 Case 3: -1
 

Source
 
题意:将最下面的那个字符串最少修改几个字符,使得不含上面的任何一条子串。。。
分析:AC自动机+DP,自动机里标记病毒结束的节点,用个或运算就是如果更长的病毒包含一个短点的病毒,长病毒里的那一段小的也要标记,然后就是DP了,dp[i][j],i代表病毒的长度,j代表节点,里面存的是在这个长度这个节点里的最小要改变的次数。。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int MAXN=1010;
const int INF=1<<30;
int dp[MAXN][MAXN];
int size;
char s[MAXN];
struct node
{
    int fail;
    int next[4];
    bool end;
    void init()
    {
        fail=0;
        end=0;
        memset(next,0,sizeof(next));
    }
}tree[MAXN];
int get(char c)
{
    if(c=='A')
        return 0;
    if(c=='T')
        return 1;
    if(c=='G')
        return 2;
    return 3;
}
void insert(char *str)
{
    int i=0,p=0,index;
    while(str[i])
    {
        index=get(str[i]);
        if(!tree[p].next[index])
        {
            tree[++size].init();
            tree[p].next[index]=size;
        }
        p=tree[p].next[index];
        i++;
    }
    tree[p].end=1;
}
void build_ac_automation()
{
    int i,p;
    queue<int> q;
    q.push(0);
    while(!q.empty())
    {
        int temp=q.front();
        q.pop();
        for(i=0;i<4;i++)
        {
            if(tree[temp].next[i])
            {
                p=tree[temp].next[i];
                if(temp!=0)
                    tree[p].fail=tree[tree[temp].fail].next[i];
                tree[p].end|=tree[tree[p].fail].end;
                q.push(p);
            }
            else
                tree[temp].next[i]=tree[tree[temp].fail].next[i];
        }
    }
}
int flag=1;
void solve(int len)
{
    int ans,i,j,k,p,t,n;
    for(i=0;i<=len;i++)
        for(j=0;j<=size;j++)
        dp[i][j]=INF;
    dp[0][0]=0;
    for(i=1;i<=len;i++)
    {
        t=get(s[i]);
        for(j=0;j<=size;j++)
        {
            if(tree[j].end||dp[i-1][j]>=INF)
                continue;
            for(k=0;k<4;k++)
            {
                p=tree[j].next[k];
                if(tree[p].end)
                    continue;
                if(k!=t)
                    dp[i][p]=min(dp[i][p],dp[i-1][j]+1);
                else
                    dp[i][p]=min(dp[i][p],dp[i-1][j]);
            }
        }
    }
    ans=INF;
    for(i=0;i<=size;i++)
        ans=min(ans,dp[len][i]);
    if(ans!=INF)
        printf("Case %d: %d\n",flag++,ans);
    else
        printf("Case %d: -1\n",flag++);
}
int main()
{
    int n;
    while(scanf("%d",&n)==1&&n)
    {
        size=0;
        tree[0].init();
        while(n--)
        {
            scanf("%s",s);
            insert(s);
        }
        build_ac_automation();
        scanf("%s",s+1);
        n=strlen(s+1);
        solve(n);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值