Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题目是全英文的,理解上有些不大习惯。
简单的翻译一下呢(按我的理解把题目意思讲一下啊)

输入一个不超过20位的正整数n,将其乘以两倍,记作k。如果k的各个位的数字,只是n的各个位上的数字的另一个排列。
那么输出Yes,否则输出No。然后在下一行输出k

题解:这题有两个点要考虑

  • 整数长度的问题,因为输入是有可能超过基本数据类型的表示范围,所以要使用一个数组来进行计算。
  • 如何判断k是n的另一个排列,很简单,只要每个数字出现的次数相同。一开始,想用map来实现,后来觉得直接用数组就好了

贴代码

#include <iostream>
#include <string>
#include <cstring>

using namespace std;


int main() {
    string s;
    getline(cin, s);
    int len = s.size();//用一个string读入数字,当然用char[]也没问题
    short *pdoudigit = new short[len+1];//考虑到要进位这个问题
    memset(pdoudigit, 0, (len+1)* sizeof(short));//清理一下空间
    int i;
    short orign[10] = {0};//用于统计数字的数组
    short later[10] = {0};
    /*迭代处理每一位数,*2,进位*/
    for (i = len ; i > 0; --i) {
        short temp = s[i-1] - '0';
        orign[temp]++;
        pdoudigit[i] += temp * 2;
        if (pdoudigit[i] / 10) {
            pdoudigit[i - 1] += 1;
            pdoudigit[i] %= 10;
        }
        later[pdoudigit[i]]++;
    }
    //首位只能为0/1
    if(pdoudigit[0])
        later[pdoudigit[0]]++;
    bool flag=true;
    //比较出现的次数
    for(i=0;i<10;++i)
    {
       if(orign[i]!=later[i])
       {flag=false;break;
        }
    }
    cout<<(flag?"Yes":"No")<<endl;
    if(pdoudigit[0])
        cout<<pdoudigit[0];
    for(i=1;i<=len;++i) {
        cout << pdoudigit[i];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值