have fun with numbers

4 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

遇到的问题如下:

1.格式问题,没有注意到yes和no的大小写问题,和no后仍要输出数字。检测点全部不通过,一般这种情况真的要考虑格式是不是错误了。

2.题目的思想可以简化为输入数字和两倍的数字包含的数字个数是一样的,即1重复的次数是一样的,2重复的次数是一样的。。。

3.×2倍时我忘记加上进位了。

4.因为最多能输入20位数,超过long long 类型的最大值了,所以采用输入字符的形式。

#include <iostream>
#include <string.h>

using namespace std;

int main()
{
  char str[25];
  int dst[25];
  int a[25]={0},b[25]={0};
  int l,n,m,p;
  int k=0;
  int flag=1;
  cin>>str;
  l=strlen(str);
  for(int i=0;i<l;i++)
  {
    n=str[i]-'0';
    a[n]++;
  }
  for(int i=l-1;i>=0;i--)
  {
    m=2*(str[i]-'0')+k;
    k=m/10;
    p=m%10;
    dst[i]=p;
    b[p]++;
  }

  if(k!=0)
  {
    flag=0;
    b[k]++;
    dst[l]=k;
  }

  if(flag==1)
  {
    for(int i=0;i<l;i++)
      {
        if(a[i]!=b[i])
          {
            flag=0;break;
          }
      }
  }

  if(flag==0)
  {
    cout<<"No"<<endl;
    if(k!=0)
    cout<<dst[l];
    for(int i=0;i<l;i++)
      {
        cout<<dst[i];
      }
  }
  else
  {
    cout<<"Yes"<<endl;
    for(int i=0;i<l;i++)
      {
        cout<<dst[i];
      }
  }
  return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值