HDU 1241 dfs 绝望的WA


Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0

Sample Output
0 1 2 2

 
真是绝望了QAQ不明白为什么一直WA
这都改得和学长给的标程一样了,还WA
我想打人,不交了,p
QAQ找到问题了,输入不知道为什么变了 //选择输入字符串是最棒的
提供一组样例= =
5 2
@@
*@
@*
*@
@@
3 3
@**
*@*
@**


#include<cstdio>
//#include<cstring>
//using namespace std;
int n,m,mark; 
char oil[105][105];
void dfs(int x,int y){
int fx[8]={0,0,-1,1,-1,1,-1,1};
int fy[8]={1,-1,0,0,1,1,-1,-1};
for(int i=0;i<8;i++){//寻找周围8个方向的@ 
int xx=x+fx[i],yy=y+fy[i];//如果有,则替换成* 
if(xx>=0&&yy>=0&&xx<m&&yy<n&&oil[xx][yy]=='@'){//注意xx,yy和m,n的对应关系 
    oil[xx][yy]='*';
   dfs(xx,yy); //并以这点为起点 寻找其他 
   
}
}
    
}
int main()
{
while(scanf("%d%d",&m,&n)){
if(m==0)break;
 mark=0;
for(int i=0;i<m;i++){
// for(int j=0;j<n;j++)我天不明白为什么好好的输入成了那个鸟样子 
  scanf("%s",&oil[i]);//还是选择字符串输入最保险 
  //getchar();//吃掉回车键  <-字符输入,一直WA 
}for(int i=0;i<m;i++){ 
//for(int j=0;j<=n;j++)测试输出= =终于找到问题了 
// printf("%s",oil[i]);
//putchar('\n');
}
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
if(oil[i][j]=='@'){//寻找@ 
mark++;
oil[i][j]='*';//标记 
dfs(i,j);//向周边扩散 
}

 
printf("%d\n",mark);
}return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值