HDU 1175 连连看

HDU 1175 连连看

题目描述
“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

这里写图片描述

Sample Input
3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0

Sample Output
YES
NO
NO
NO
NO
YES

思路
简单dfs即可

代码如下

#include <iostream> 
#include <cstdio>
#include <cstdlib>
#include <fstream>
#include <math.h>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#include<sstream>
#include<ctime>
using namespace std;
int dix[4]={0,1,0,-1};
int diy[4]={1,0,-1,0};
int map[1005][1005];
int f[1005][1005];
int n,m,ex,ey,sx,sy,flag; 
void dfs(int x,int y,int dir)
{
    if(f[x][y]>=3||flag==1)
    return;
    if(x==ex&&y==ey)
    {
        flag=1;
        cout<<"YES\n";
        return;
    }
    for(int i=0;i<4;i++)
    {
        int tx=x+dix[i];
        int ty=y+diy[i];
        if(tx>=1&&tx<=n&&ty>=1&&ty<=m&&map[tx][ty]==0&&f[tx][ty]>=f[x][y])
        {

            if(dir!=-1&&dir!=i&&f[x][y]==f[tx][ty])
            continue;
            if(dir!=-1&&dir!=i&&f[x][y]<2)
            {
               f[tx][ty]=f[x][y]+1;
            }
            else if(dir==-1||dir==i)
            {
               f[tx][ty]=f[x][y];
            }
            dfs(tx,ty,i);
        }
    }
}
int main()
{
    while(1)
    {
        cin>>n>>m;
        if(!(n+m))
        break;
        for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        cin>>map[i][j];
        int q;
        cin>>q;
        for(int i=1;i<=q;i++)
        {
            for(int j=1;j<=n;j++)
            for(int k=1;k<=m;k++)
            f[j][k]=3;
            flag=0;
            cin>>sx>>sy>>ex>>ey;
            if(map[sx][sy]==map[ex][ey]&&map[sx][sy]!=0)
            {
                map[ex][ey]=0;
                f[sx][sy]=0;
               dfs(sx,sy,-1);
               map[ex][ey]=map[sx][sy];
             }
            if(flag==0)
            cout<<"NO\n";
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值