Description
Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people’s memories about some period of life.
A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.
Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.
Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.
Input
The first line of the input contains n - the number of days of Bill’s life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, … an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
Print the greatest value of some period of Bill’s life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.
Sample Input
6
3 1 6 4 5 2
Sample Output
60
3 5
大致题意:给定n个非负整数 ,一个区间的权值定义为这个区间的最小数乘以这个区间所有数的 和
让你求最大权值的区间。
思路:很经典的单调栈的运用。
代码如下
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<string>
#define LL long long
using namespace std;
const int maxn=1e5+5;
LL sum[maxn];
int a[maxn];
int lef[maxn];
int stack[maxn];
int main()
{
int n;
sum[0]=0;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum[i]=sum[i-1]+a[i];
}
n++;
a[n]=-1;
int top=0;
LL ans=-1;
int ll,rr;
for(int i=1;i<=n;i++)
{
if(top==0||a[i]>a[stack[top-1]])
{
stack[top++]=i;
lef[i]=i;
continue;
}
if(a[i]==a[stack[top-1]])
continue;
while(top>=1&&a[i]<a[stack[top-1]])
{
top--;
LL tmp=a[stack[top]]*(sum[i-1]-sum[lef[stack[top]]-1]);
if(tmp>ans)
{
ans=tmp;
ll=lef[stack[top]];
rr=i-1;
}
}
lef[i]=lef[stack[top]];
stack[top++]=i;
}
printf("%lld\n%d %d\n", ans, ll, rr);
return 0;
}