[POJ2796]Feel Good

Time Limit: 3000MS
Memory Limit: 65536K
Case Time Limit: 1000MS
Special Judge

Description
Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people’s memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life.

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input
The first line of the input contains n - the number of days of Bill’s life he is planning to investigate ( 1 &lt; = n &lt; = 100000 ) (1 &lt;= n &lt;= 100 000) (1<=n<=100000). The rest of the file contains n integer numbers a 1 , a 2 , . . . a n a_1, a_2, ... a_n a1,a2,...an ranging from 0 0 0 to 1 0 6 10^6 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output
Print the greatest value of some period of Bill’s life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

题意:
求一个区间,使得(区间和*区间最小值)最大
输出ans和任意一个答案区间

题解:
枚举每个点,询问将其当作区间最小值的最大区间和是多少
由于所有数字都是非负数,所以区间越长越好,记L[i]为第i个元素为最小值的区间最左端,记R[i]为第i个元素为最小值的区间最右端。用单调栈来解决这个问题。(正反各扫一遍)

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<stack>
#define LiangJiaJun main
#define ll long long
#define pa pair<int,int>
using namespace std;
int n,a[100004];
stack<pa>st;
ll s[100004];
int L[100004],R[100004];
int w33ha(){
    s[0]=0;
    while(!st.empty())st.pop();
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
        s[i]=s[i-1]+a[i];
    }
    for(int i=1;i<=n;i++){
        while(!st.empty()&&st.top().first>=a[i])st.pop();
        if(st.empty())L[i]=1;
        else L[i]=st.top().second+1;
        st.push(make_pair(a[i],i));
    }
    while(!st.empty())st.pop();
    for(int i=n;i>=1;i--){
        while(!st.empty()&&st.top().first>=a[i])st.pop();
        if(st.empty())R[i]=n;
        else R[i]=st.top().second-1;
        st.push(make_pair(a[i],i));
    }
    ll ans=-1;
    int ansl=0,ansr=0;
    for(int i=1;i<=n;i++){
        if(ans<(s[R[i]]-s[L[i]-1])*1LL*a[i]){
            ans=(s[R[i]]-s[L[i]-1])*1LL*a[i];
            ansl=L[i];
            ansr=R[i];
        }
    }
    printf("%lld\n%d %d\n",ans,ansl,ansr);
    return 0;
}
int LiangJiaJun(){
    while(scanf("%d",&n)!=EOF)w33ha();
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值