hdu1556 Color the ball(线段树区间修改)

Problem Description
N个气球排成一排,从左到右依次编号为1,2,3….N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽”牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

Sample Input
3
1 1
2 2
3 3
3
1 1
1 2
1 3
0

Sample Output
1 1 1
3 2 1

代码如下

#include <cstdio>  
#include <algorithm>    
#define lson l , m , rt << 1  
#define rson m + 1 , r , rt << 1 | 1  
#define LL long long  
using namespace std;
const int maxn =100005;  
int lazy[maxn<<2];  
int sum[maxn<<2]; 

void PushUp(int rt) 
{  
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];  
}  
void PushDown(int rt,int m)
{  
    if(lazy[rt])
    {  
        lazy[rt<<1]+=lazy[rt];  
        lazy[rt<<1|1]+=lazy[rt];  
        sum[rt<<1]+=lazy[rt]*(m-(m>>1));  
        sum[rt<<1|1]+=lazy[rt]*(m>>1);  
        lazy[rt]=0;  
    }  
}  

void build(int l,int r,int rt) 
{  
    lazy[rt] = 0;  
    if(l==r) 
    {  
        //scanf("%intd",&sum[rt]); 
        sum[rt]=0; 
        return ;  
    }  
    int m=(l+r)>>1;  
    build(lson);  
    build(rson);  
    PushUp(rt);  
}  

void update(int L,int R,int c,int l,int r,int rt) 
{  
    if (L<=l&&r<=R) 
    {  
        lazy[rt]+=c;

        sum[rt]+=(int)c*(r-l+1);  

        return ;  
    }  
    PushDown(rt,r-l+1);  
    int m=(l+r)>>1;  
    if (L<=m) update(L,R,c,lson);  
    if (m<R) update(L,R,c,rson);  
    PushUp(rt);  
}  

int query(int L,int R,int l,int r,int rt) 
{  
    if (L<=l&&r<=R) 
    {  
        return sum[rt];  
    }  
    PushDown(rt,r-l+1);  

    int m=(l+r)>>1;  
    int ret = 0;  
    if (L<=m) ret+=query(L,R,lson);  
    if (m<R) ret+=query(L,R,rson);  
    return ret;  
}  
int main() 
{  
    int n;  

    while(scanf("%d",&n)&&n!=0)
    {

        build(1,n,1);  
        int q=n;
        while(q--) 
        {  
            int x,y;
            scanf("%d%d",&x,&y);
            update(x,y,1,1,n,1); 
        }
        for(int i=1;i<=n;i++)
            printf(i==1?"%d":" %d",query(i,i,1,n,1));
        printf("\n");
    } 
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值