Mathematically Hard LightOJ - 1007 (欧拉筛+前缀和)

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.

Input
Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output
For each case, print the case number and the summation of all the scores from a to b.

Sample Input
3
6 6
8 8
2 20
Sample Output
Case 1: 4
Case 2: 16
Case 3: 1237
这里写图片描述

大致题意:就是让你求区间[a,b]内的各个数的欧拉值平方的和

思路:先用欧拉筛打个表,然后用前缀和预处理下,注意最后结果会爆longlong,得用unsign long long,然后内存也得注意下,写搓了很容易爆。

代码如下

#include<bits/stdc++.h>
using namespace std;
#define LL long long 
#define ULL unsigned long long 
const int M=5000010;

ULL p[M];//先用于欧拉筛里存素数,然后再用来保存前缀和,如果再开一个数组的话会爆内存
int phi[M];
bool vis[M];
int p_num=0;
void get_phi()
{
    for(int i=2;i<=M;i++)
    {
        if(!vis[i])
        {
            p[p_num++]=i;
            phi[i]=i-1;
        }
        for(int j=0;j<p_num&&p[j]*i<=M;j++)
        {
            vis[p[j]*i]=1;
            if(i%p[j]==0)
            {
                phi[i*p[j]]=phi[i]*p[j];
                break;
            }
            else 
            phi[i*p[j]]=phi[i]*(p[j]-1);
        }
    }
}
int main()
{
    get_phi();
    phi[1]=1;
    p[0]=0;
    for(int i=1;i<=M;i++)
    {
        p[i]=(ULL)phi[i]*phi[i]+p[i-1];//注意phi[i]*phi[i]会爆int
    }
    int T,a,b;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++)
    {
        scanf("%d%d",&a,&b);
        printf("Case %d: %llu\n",cas,p[b]-p[a-1]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值