poj3278&&luogu2685&&luogu1588

Catch That Cow
Time Limit: 2000MS

Memory Limit: 65536K
Total Submissions: 92986

Accepted: 29165
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source
USACO 2007 Open Silver

bfs一下就可以了,注意边界条件,别出界

#include<cstdio>
#include <cstring>
int const N=110000;
int sf,sc,op,cl,f1,dep1;
bool flag[N];
struct node{
    int f;
    int dep;
};
node data[N];
int main(){
    //freopen("poj3278.in","r",stdin);
    //freopen("poj3278.out","w",stdout);

    scanf("%d%d",&sf,&sc);
    //printf("%d%d\n",sf,sc);
    if(sf==sc){
        printf("0\n");
        return 0;
    }
    data[1].f=sf;
    data[1].dep=0;
    //printf("%d",data[1].f);
    memset(flag,true,sizeof flag);
    flag[sf]=false;
    //if(!flag[1]) printf("1");

    op=0;cl=1;
    while(op<cl){
        ++op;

        dep1=data[op].dep;

        f1=data[op].f+1;

        if(f1<=N&&flag[f1]){
            ++cl;

            data[cl].f=f1;
            data[cl].dep=dep1+1;
            flag[f1]=false;

            if(f1==sc){
                printf("%d\n",data[cl].dep);
                return 0;
            }
        }

        f1=data[op].f-1;

        if(f1>=0&&flag[f1]){
            ++cl;
            data[cl].f=f1;
            data[cl].dep=dep1+1;
            flag[f1]=false;
            if(f1==sc){
                printf("%d\n",data[cl].dep);
                return 0;
            }
        }

        f1=data[op].f*2;

        if(f1<=N&&flag[f1]){
            ++cl;
            data[cl].f=f1;
            data[cl].dep=dep1+1;
            flag[f1]=false;
            if(f1==sc){
                printf("%d\n",data[cl].dep);
                return 0;
            }
        }
    }
    return 0;
}

1588就是多组测试数据 双倍经验hh

#include<cstdio>
#include <cstring>
int const N=110000;
int sf,sc,op,cl,f1,dep1;
bool flag[N];
struct node{
    int f;
    int dep;
};
node data[N];
int main(){
    freopen("poj3278.in","r",stdin);
    //freopen("poj3278.out","w",stdout);
    int t;scanf("%d",&t);
    while (t--){
        scanf("%d%d",&sf,&sc);
        //printf("%d%d\n",sf,sc);
        if(sf==sc){
            printf("0\n");
            continue;
        }
        data[1].f=sf;
        data[1].dep=0;
        //printf("%d",data[1].f);
        memset(flag,true,sizeof flag);
        flag[sf]=false;
        //if(!flag[1]) printf("1");

        op=0;cl=1;
        while(op<cl){
            ++op;

            dep1=data[op].dep;

            f1=data[op].f+1;

            if(f1<=N&&flag[f1]){
                ++cl;

                data[cl].f=f1;
                data[cl].dep=dep1+1;
                flag[f1]=false;

                if(f1==sc){
                    printf("%d\n",data[cl].dep);
                    break;
                }
            }

            f1=data[op].f-1;

            if(f1>=0&&flag[f1]){
                ++cl;
                data[cl].f=f1;
                data[cl].dep=dep1+1;
                flag[f1]=false;
                if(f1==sc){
                    printf("%d\n",data[cl].dep);
                    break;
                }
            }

            f1=data[op].f*2;

            if(f1<=N&&flag[f1]){
                ++cl;
                data[cl].f=f1;
                data[cl].dep=dep1+1;
                flag[f1]=false;
                if(f1==sc){
                    printf("%d\n",data[cl].dep);
                    break;
                }
            }
        }
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值