poj2155 二维树状数组

http://www.elijahqi.win/archives/647

Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1

段修改改为点修改 二维同理 求单点的时候等于求和
例如 wanna change from(1,3)to(3,5)
0 0 0 0 0 0 0 1 0 -1
0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 —————————–> 0 0 -1 0 1 (要补上多减去的1)
0 0 0 0 0 0 0 0 0 0

#include <cstdio>
#include <cstring>
#define N 1100
int map[N][N],x,n,t;
void add(int x,int y,int v){
    while (x<=n){
        int j=y;
        while (j<=n){
            map[x][j]+=v;j+=j&(-j);
        }
        x+=x&(-x);
    }
}
int getsum(int x,int y){
    int ans=0;
    while (x>0){
        int j=y;
        while (j>0){
            ans+=map[x][j];
            j-=j&(-j);
        }
        x-=x&(-x);
    }
    return ans;
}
int main(){
    freopen("poj2155.in","r",stdin);
    freopen("poj2155.out","w",stdout);
    scanf("%d",&x);
    while (x--){
        memset(map,0,sizeof(map));//注意清0
        scanf("%d%d",&n,&t);
        char str1[5];
        for (int i=1;i<=t;++i){
            scanf("%s",str1);
            if (str1[0]=='C'){
                int x1,x2,y1,y2;
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                add(x1,y1,1);add(x1,y2+1,-1);
                add(x2+1,y1,-1);add(x2+1,y2+1,1);

            }else{
                int x,y;
                scanf("%d%d",&x,&y);
                printf("%d\n",getsum(x,y)%2);
            }
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值