题目
D - Matrix
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).
We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
- C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
- Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output
For each querying output one line, which has an integer representing A[x, y].
There is a blank line between every two continuous test cases.
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1
Translate
有一个N*N的矩阵,元素值只可能是0或1。现在有两种操作:
1.C x1 y1 x2 y2:将矩形(x1,y1,x2,y2)的元素全部取反。
2.Q x y:查询(x,y)处的值。
输入数据:
第一行给出测试数据的组数X,接下来有X组数据,每组数据的第一行有两个整数N和T。N表示矩阵的边长,T表示操作的次数。N<=1000,T<=50000.接下来T行操作,如上所示。
输出数据:
对于每组数据的每次查询,输出一个整数,表示查询的结果。
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <map>
#include <math.h>
#include <vector>
#include <set>
#include <queue>
#include <map>
#include <deque>
using namespace std;
typedef long long ll;
const int N=1e3+70;
int n,m;
int tree[N][N],a[N][N];
int lowbit(int x)
{
return x&(-x);
}
void update(int x,int y,int k)
{
for(int i=x;i<=n;i+=lowbit(i))
for(int j=y;j<=n;j+=lowbit(j))
tree[i][j]+=k;
}
int sum(int x,int y)
{
int ans=0;
for(int i=x;i>=1;i-=lowbit(i))
for(int j=y;j>=1;j-=lowbit(j))
ans+=tree[i][j];
return ans;
}
int main()
{
int t,l,r,p,q;
scanf("%d",&t);
while(t--)
{
memset(tree,0, sizeof(tree));
scanf("%d %d",&n,&m);
while(m--)
{
char x;
scanf(" %c ",&x);
if(x=='C')
{
scanf("%d %d %d %d",&l,&r,&p,&q);
update(l,r,1);
update(l,q+1,1);
update(p+1,r,1);
update(p+1,q+1,1);//类似一维的更新
}
else
if(x=='Q')
{
scanf("%d %d",&l,&r);
printf("%d\n",sum(l,r)%2);
}
}
printf("\n");
}
return 0;
}