poj2823 Sliding Window

http://www.elijahqi.win/archives/983
Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input

8 3
1 3 -1 -3 5 3 6 7
Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7
单调队列的题咳咳 告诉自己不要浮躁,不要急于追求结果

这题注意下poj上不知道为什么c++编译才行,否则会tle

维护最大值&最小值,我们设立两个单调队列

并且每个队列都是两个指针

先说最小值:我们维护递增的序列

当左指针所指位置存的值不在我们的框内,我们选择右移左指针,当我队列里的值大于我新入队的值,我把右指针回移,相当于弹出

再说最大值:我们维护递减的序列

当做指针所指位置存的值不在我们的框内,我们选择右移左指针,这次,当队列中的值小于我新入队的值的话,将右指针回移,弹出我们的不满足条件的数据

#include<cstdio>
#define N 1100000
inline int read(){
    int x=0,f=1;char ch=getchar();
    while (ch<'0'||ch>'9'){if (ch=='-') f=-1;ch=getchar();}
    while (ch<='9'&&ch>='0'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int up[N],down[N],ans1[N],ans2[N],a[N],n,k,r1,r2; 
int main(){
    freopen("poj2823.in","r",stdin);
    while (~scanf("%d%d",&n,&k)){
        for (int i=1;i<=n;++i) a[i]=read();
        int l1=1,l2=1;r1=r2=0;
        for (int i=1;i<=n;++i){
            while (l1<=r1&&down[l1]<=i-k) ++l1;
            while (l2<=r2&&up[l2]<=i-k) ++l2;
            while (l1<=r1&&a[i]<a[down[r1]]) r1--;down[++r1]=i;
            while (l2<=r2&&a[i]>a[up[r2]]) r2--;up[++r2]=i;
            ans1[i]=a[down[l1]];ans2[i]=a[up[l2]];
        }
        for (int i=k;i<=n;++i) printf("%d ",ans1[i]);printf("\n");
        for (int i=k;i<=n;++i) printf("%d ",ans2[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值