poj 2823 Sliding Window

Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 36147 Accepted: 10700
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7
线段树、区间求最值

#include"stdio.h"
#include"string.h"
#define N 1000005
int num[N];
int aa[N],bb[N];          //记录最大最小值
struct node
{
	int l,r,num,min,max;
}f[N*3];
int Min(int a,int b)          
{
	return a<b?a:b;
}
int Max(int a,int b)
{
	return a>b?a:b;
}
void creat(int t,int l,int r)
{
	f[t].l=l;
	f[t].r=r;
	if(l==r)
	{
		f[t].num=f[t].max=f[t].min=num[r];
		return ;
	}
	int temp=t*2,mid=(l+r)/2;   
	creat(temp,l,mid);
	creat(temp+1,mid+1,r);
	f[t].max=Max(f[temp].max,f[temp+1].max);
	f[t].min=Min(f[temp].min,f[temp+1].min);
	return ;
}
int fmax(int t,int l,int r)
{
	if(f[t].l>=l&&f[t].r<=r)
		return f[t].max;
	int temp=t*2,mid=(f[t].l+f[t].r)/2;
	if(mid>=r)
		return fmax(temp,l,r);
	else if(mid<l)
		return fmax(temp+1,l,r);
	else
		return Max(fmax(temp,l,mid),fmax(temp+1,mid+1,r));
}
int fmin(int t,int l,int r)
{
	if(f[t].l>=l&&f[t].r<=r)
		return f[t].min;
	int temp=t*2,mid=(f[t].l+f[t].r)/2;
	if(mid>=r)
		return fmin(temp,l,r);
	else if(mid<l)
		return fmin(temp+1,l,r);
	else
		return Min(fmin(temp,l,mid),fmin(temp+1,mid+1,r));
}
int main()
{
	int n,m,i;
	while(scanf("%d%d",&n,&m)!=-1)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&num[i]);
		creat(1,1,n);
		int a=1,b,k=0;
		while(a<=n-m+1)
		{
			b=a+m-1;
			aa[k]=fmin(1,a,b);
			bb[k++]=fmax(1,a,b);
			a++;
		}
		for(i=0;i<n-m;i++)
			printf("%d ",aa[i]);
		printf("%d\n",aa[n-m]);
		for(i=0;i<n-m;i++)
			printf("%d ",bb[i]);
		printf("%d\n",bb[n-m]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值