hdu4089 Activation

149 篇文章 0 订阅
14 篇文章 0 订阅

http://www.elijahqi.win/archives/3630
Problem Description
After 4 years’ waiting, the game “Chinese Paladin 5” finally comes out. Tomato is a crazy fan, and luckily he got the first release. Now he is at home, ready to begin his journey.
But before starting the game, he must first activate the product on the official site. There are too many passionate fans that the activation server cannot deal with all the requests at the same time, so all the players must wait in queue. Each time, the server deals with the request of the first player in the queue, and the result may be one of the following, each has a probability:
1. Activation failed: This happens with the probability of p1. The queue remains unchanged and the server will try to deal with the same request the next time.
2. Connection failed: This happens with the probability of p2. Something just happened and the first player in queue lost his connection with the server. The server will then remove his request from the queue. After that, the player will immediately connect to the server again and starts queuing at the tail of the queue.
3. Activation succeeded: This happens with the probability of p3. Congratulations, the player will leave the queue and enjoy the game himself.
4. Service unavailable: This happens with the probability of p4. Something just happened and the server is down. The website must shutdown the server at once. All the requests that are still in the queue will never be dealt.
Tomato thinks it sucks if the server is down while he is still waiting in the queue and there are no more than K-1 guys before him. And he wants to know the probability that this ugly thing happens.
To make it clear, we say three things may happen to Tomato: he succeeded activating the game; the server is down while he is in the queue and there are no more than K-1 guys before him; the server is down while he is in the queue and there are at least K guys before him.
Now you are to calculate the probability of the second thing.

Input
There are no more than 40 test cases. Each case in one line, contains three integers and four real numbers: N, M (1 <= M <= N <= 2000), K (K >= 1), p1, p2, p3, p4 (0 <= p1, p2, p3, p4 <= 1, p1 + p2 + p3 + p4 = 1), indicating there are N guys in the queue (the positions are numbered from 1 to N), and at the beginning Tomato is at the Mth position, with the probability p1, p2, p3, p4 mentioned above.

Output
A real number in one line for each case, the probability that the ugly thing happens.
The answer should be rounded to 5 digits after the decimal point.

Sample Input
2 2 1 0.1 0.2 0.3 0.4 3 2 1 0.4 0.3 0.2 0.1 4 2 3 0.16 0.16 0.16 0.52

Sample Output
0.30427 0.23280 0.90343
有n个人排队等着在官网上激活游戏。Tomato排在第m个。
对于队列中的第一个人。有一下情况:
1、激活失败,留在队列中等待下一次激活(概率为p1)
2、失去连接,出队列,然后排在队列的最后(概率为p2)
3、激活成功,离开队列(概率为p3)
4、服务器瘫痪,服务器停止激活,所有人都无法激活了。
求服务器瘫痪时Tomato在队列中的位置<=k的概率
设dp[i][j]表示队伍长度为i 现在处于j位置 最后满足要求的概率是多少

j==1:dp[i][1]=p1dp[i][1]+p2dp[i][i]+p41 j == 1 : d p [ i ] [ 1 ] = p 1 ∗ d p [ i ] [ 1 ] + p 2 ∗ d p [ i ] [ i ] + p 4 ∗ 1
2jk:dp[i][j]=p1dp[i][j]+p2dp[i][j1]+p3dp[i1][j1]+p41 2 ≤ j ≤ k : d p [ i ] [ j ] = p 1 ∗ d p [ i ] [ j ] + p 2 ∗ d p [ i ] [ j − 1 ] + p 3 ∗ d p [ i − 1 ] [ j − 1 ] + p 4 ∗ 1
k<ji:dp[i][j]=p1dp[i][j]+p2dp[i][j1]+p3dp[i1][j1] k < j ≤ i : d p [ i ] [ j ] = p 1 ∗ d p [ i ] [ j ] + p 2 ∗ d p [ i ] [ j − 1 ] + p 3 ∗ d p [ i − 1 ] [ j − 1 ]
有了dp方程还不行 卡了我半天 最后翻题解 还得化简再手动高斯消元
具体参见大佬bloghttps://www.cnblogs.com/jianglangcaijin/archive/2013/05/04/3060411.html

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
inline double ksm(double b,int t){static double tmp;
    for (tmp=1;t;b=b*b,t>>=1) if(t&1) tmp=tmp*b;return tmp;
}
double dp[2001][2001];double p1,p2,p3,p4;int n,m,k;
int main(){
    freopen("hdu4089.in","r",stdin);
    while(~scanf("%d%d%d%lf%lf%lf%lf",&n,&m,&k,&p1,&p2,&p3,&p4)){
        if (p4<1e-5) {puts("0.00000");continue;}
        double p21=p2/(1-p1),p31=p3/(1-p1),p41=p4/(1-p1);
        dp[1][1]=p4/(1-p1-p2);
        for (int i=2;i<=n;++i){dp[i][i]=0;
            for (int j=1;j<=i;++j){
                if (j==1) dp[i][i]+=ksm(p21,i-j)*p41;
                else if (j>1&&j<=k) dp[i][i]+=ksm(p21,i-j)*(p31*dp[i-1][j-1]+p41);
                else dp[i][i]+=ksm(p21,i-j)*p31*dp[i-1][j-1];
            }dp[i][i]/=1-ksm(p21,i);
            for (int j=1;j<i;++j){
                if (j==1) dp[i][j]=p21*dp[i][i]+p41;
                else if (j>1&&j<=k) dp[i][j]=p21*dp[i][j-1]+p31*dp[i-1][j-1]+p41;
                else dp[i][j]=p21*dp[i][j-1]+p31*dp[i-1][j-1];
            }
        }printf("%.5f\n",dp[n][m]);
    }
    return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值