zoj1048体会

                                                                    

Financial Management

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.


Input Format:

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.


Output Format:

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input:

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75


Sample Output:

$1581.42

 

我第一次的代码:

#include<stdio.h>

void main()
{
 float d,sum,average;
 int i;

while(1)
    sum=0;
    for(i=0;i<12;i++)
    {
     scanf("%f",&d);
     sum+=d;
    }
    average=sum/12;
    printf("$%.2f/n",average);

}
}

结果TLE,不能ac;这是因为我原来做hdu的题目,习惯了多个测试案例,本题目的意思是只有一个测试用例,不需要while循环;

去掉while循环后,语言选择C(gcc4.4.5),提交后出现non-zero exit code;语言选择C++(g++4.4.5)提交后是编译错误,原因是main必须return,改成如下代码后则可以ac。

#include<stdio.h>

int main()
{
 float d,sum,average;
 int i;
    sum=0;
    for(i=0;i<12;i++)
    {
     scanf("%f",&d);
     sum+=d;
    }
    average=sum/12;
    printf("$%.2f/n",average);
    return 0;
}

总结如下,在zoj上做题时要看清题意,用C或C++main必须有return

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值