PAT-1063 Set Similarity

1063 Set Similarity (25)(25 分)

Given two sets of integers, the similarity of the sets is defined to be N~c~/N~t~*100%, where N~c~ is the number of distinct common numbers shared by the two sets, and N~t~ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=10^4^) and followed by M integers in the range [0, 10^9^]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

set已经排好序,遍历一次即可找出相同元素个数。如果在getS()函数中使用一个新set,把两个set插入到里边看新set的大小也可以知道重复元素,之前偷懒这么写超时了,以为是set(红黑树)插入比较慢,结果换成unordered_set(散列)还是超时,时间只快了不到30%,看来STL容器元素的拷贝相比遍历还是挺费时的,应尽量避免。

#include<stdio.h>
#include<set>
#include<algorithm>
using namespace std;

set<int> v[51];
double t[50][50]={0};
double getS(int s1,int s2){
	if(t[s2][s1]>0)
		return t[s2][s1];

	int same=0,diff=0;
	auto it2=v[s2].begin(),it1=v[s1].begin();
	for(;it2!=v[s2].end()&&it1!=v[s1].end();){
		if(*it1>*it2)
			it2++;
		else if(*it2>*it1)
			it1++;
		else
		{same++;it1++;it2++;}
	}
	diff=v[s1].size()+v[s2].size()-same;
	t[s1][s2]=t[s2][s1]=same*100.0/diff;
	return t[s2][s1];

}
int main(){
	int n;
	scanf("%d",&n);
	fill(t[0],t[49]+50,-1);
	for(int i=1;i<=n;i++){
		int m;
		scanf("%d",&m);
		for(int j=0;j<m;j++){
			int t;
			scanf("%d",&t);
			v[i].insert(t);
		}
	}
	int k;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		int t1,t2;
		scanf("%d %d",&t1,&t2);
		double f=getS(t1,t2);
		printf("%.1f%%\n",f);
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值