PAT-A-1063 Set Similarity 【set】

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

看到distinct就想到了set的使用。

我当时这样想,使用set数组保存每个数字序列,当让求某两个序列的相似度时,使用两个set变量,one、two分别等于这两个序列,然后将一个序列插入到一个另一个序列中,这样分母就是得到的新序列的长度,分子就是 one、two插入操作之前的size之和减去插入操作之后的size,但是很遗憾,由于多次使用set进行操作,有一组测试用例超时了。

#include <iostream>
#include <set>
using namespace std;
int main(){
	int num,temp,a;
	set<int> res[50];
	scanf("%d",&num);
	for(int i=0;i<num;i++){
		scanf("%d",&temp);
		for(int j=0;j<temp;j++){
			scanf("%d",&a);
			res[i].insert(a);
		}
	}
	int m,one,two;
	set<int> temp_one,temp_two;
	scanf("%d",&m);
	while(m--){
		scanf("%d %d",&one,&two);
		temp_one=res[one-1];
		temp_two=res[two-1];
		int sizea=temp_one.size();
		int sizet=temp_two.size();
		temp_one.insert(temp_two.begin(),temp_two.end());
		int size=temp_one.size();
		printf("%.1lf%\n",100*((double)sizea+sizet-temp_one.size())/temp_one.size());
	}
	return 0;
}

既然找到了引起超时的原因是因为大量的使用set运算,那么针对于这部分进行改进,使用遍历的思路。 

下面是查询过程,使用指针遍历set,使用count查询是否为公共元素

int m,count=0;
	scanf("%d",&m);
	while(m--){
		count=0;
		scanf("%d %d",&one,&two);
		for(set<int>::iterator lt=res[one-1].begin();lt!=res[one-1].end();lt++){
			if(res[two-1].count(*lt)==1) count++;
		}
		printf("%.1lf%%\n",100*((double)count)/(res[one-1].size()+res[two-1].size()-count));
	}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值