PAT-1115 Counting Nodes in a BST

1115 Counting Nodes in a BST(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the Nintegers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and nis the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

    统计最后两层节点数。

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int id=0;
typedef struct node{
	int v,id;
	node *left,*right;
}node;
node root;
int level[2000]={0};
void insertBST(node* root,node *n,int lev){
	if(n->v>root->v){
		if(root->right==NULL){
			root->right=n;
			level[lev]++;
			return;
		}else{
			insertBST(root->right,n,lev+1);
		}
	}else{
		if(root->left==NULL){
			root->left=n;
			level[lev]++;
			return;
		}else{
			insertBST(root->left,n,lev+1);
		}
	}

}
void insert(int v){
	node* n=(node*)malloc(sizeof(node));
	n->v=v;
	n->left=NULL;
	n->right=NULL;
	n->id=id++;
	insertBST(&root,n,1);
}
int main(){
	int n;
	scanf("%d",&n);
	int t;
	for(int i=0;i<n;i++){
		scanf("%d",&t);
		if(i==0){
			root.v=t;root.id=id++;
			root.left=NULL;
			root.right=NULL;
		}else{
			insert(t);
		}
	}

	level[0]=1;int i=0;
	for(;level[i]!=0;i++)
		;
	int lev1=level[i-1];
	int lev2=level[i-2];
	printf("%d + %d = %d",lev1,lev2,lev1+lev2);

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值