1115 Counting Nodes in a BST (30分)

121 篇文章 0 订阅
115 篇文章 0 订阅

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

题解:

直接用链表创建树.创建时用hash保存每层的节点数即可 .

测试点5 可能给的样例树高不到2.需要输出0

 

#include <iostream>
using namespace std;

struct node
{
	int data, depth;
	node* left, *right;
};
int hashmap[1010];
node* newnode(int data, int depth) {
	node* tn = new node;
	tn->data = data;
	tn->depth = depth + 1;
	hashmap[depth + 1]++;
	tn->left = tn->right = NULL;
	return tn;
}
void insert(node *&root, int data, int depth) {
	if (root == NULL) {
		root = newnode(data, depth);
		return;
	}
	if (data > root->data) insert(root->right, data, root->depth);
	if (data <= root->data) insert(root->left, data, root->depth);
}
int main() {
	int n;
	cin >> n;
	node *root;
	for (int i = 0; i < n; i++)
	{
		int temp;
		cin >> temp;
		if (i == 0) root = newnode(temp, 0);
		else
		{
			insert(root, temp, 0);
		}
	}
	int cnt = 0, n1 = 0, n2 = 0;
	for (int i = 1001; i > 0; i--)
	{
		if (hashmap[i] == 0) continue;
		if (cnt == 0) 
		{
			n1 = hashmap[i];
			cnt++;
			continue;
		}
		if (cnt == 1) {
			n2 = hashmap[i];
			break;
		}
	}
	printf("%d + %d = %d", n1, n2, n1 + n2);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值